1

I'm trying to connect an external monitor using the USB-C port and an adapter on my Asus laptop, using Ubuntu.

I know the setup (cable, adapter, monitor) are all working because I can connect it on a Dell laptop running the same Ubuntu version.

Here are some specs:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 20.04.1 LTS
Release:    20.04
Codename:   focal


$ uname -a
Linux bl-asus 5.4.0-58-generic #64-Ubuntu SMP Wed Dec 9 08:16:25 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Notice how there's no Display Port in xrandr:

$ xrandr
Screen 0: minimum 320 x 200, current 1600 x 900, maximum 16384 x 16384
eDP-1 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 293mm x 165mm
   1920x1080     60.05 +  60.01    59.97    59.96    59.93  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   ... etc
   320x180       59.84    59.32  
HDMI-1 disconnected (normal left inverted right x axis y axis)

My video card is an Intel UHD Graphics 620, which I believe supports a Display Port connection.

$ sudo lshw -c video
  *-display                 
       description: VGA compatible controller
       product: UHD Graphics 620
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:128 memory:ee000000-eeffffff memory:d0000000-dfffffff ioport:f000(size=64) memory:c0000-dffff

Any ideas on how I can get it to recognize the Display Port and connect to an external monitor via USB-C?


EDIT: After testing what MacGuffin pointed below, it seems simply that my laptop (Asus UX330A) does not support video over USB-C. See: https://www.reddit.com/r/linuxhardware/comments/7o0lsv/usbc_functionality_on_asus_ux330ua/ and https://www.asus.com/support/FAQ/1042843/.

2

There's two things I suggest you check, the cable and the computer BIOS.

First check that you have a quality cable that complies with the USB-C and DisplayPort specifications. I know you said you tested this cable on another computer and it works there but that may simply mean the other computer isn't following the spec and/or is more forgiving of cables that violate the spect as written. The people that make these cables pay a lot of money for getting their cables tested, and with this money cones the right to put on their cables the USB "trident" icon, the Thunderbolt "spark", or the DisplayPort stylized "DP". Don't go running out a buy a new cable if you don't see any of these icons, just keep that in mind as a possibility as you check other possible problems.

Even if your cable meets USB-C and DisplayPort specifications there's also more than one specification. USB-C is required to supply a minimum of 7.5 watts, it's possible there's some electronics in the cable that needs more than this and that the port doesn't supply the required power. Theres more than one grade of DisplayPort cable, and your setup may require a higher grade of cable than you have. One way to grade them is RBR (reduced bit rate, supports 1080i), standard (supports 4K though perhaps at low refresh rates), and DP8K (tested to support 8K resolution). Another is to rate them by the version of DisplayPort they support, which can be 1.0, 1.2, 1.3, 1.4, or 2.0. Another is by the data rate they support, which can be anywhere from 5 to 80 Gbps. To confuse things further is that there's at least one more standard to indicate the bandwidth of the cable.

It's hard to say what kind of cable you need but if you are using USB-C to DisplayPort then the cable should have some indication of meeting the DP 1.2 spec or newer.

A second thing I suggest to check is the BIOS settings on the computer. Reading the forum link you gave would suggest that some computers will not output DisplayPort to USB-C unless explicitly enabled. Enabling DP output on USB-C could come with disabling any HDMI port the computer might have (which is not likely a concern for you). Enabling DP output on USB-C might come with losing USB 3.0 on the port, because DisplayPort and USB 3.0 use the same "superspeed" wires on the connector and only one of them can use those wires at a time. Most computers will make this switch between USB 3.0 and DisplayPort automatically depending on which kind of cable the computer detects, which I suspect the Dell computer does that you tested the cable with. This lack of automatic switching appears to be most common on computers with Intel graphics. You can speculate as well as I can on why this is.

I suggest looking in the BIOS for some setting to enable DP output to the USB-C port. I suggest checking that the cable is up to spec, and testing with another cable if possible. If you don't see an option for DP output in the BIOS, and the cable appears to be up to spec, then it's possible the computer simply does not support DisplayPort video output.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.