0

So, it has been 17 months since Buster release (and setting Bullseye as testing) and I still cannot complete the Buster to Bullseye upgrade. It's not the first time I am upgrading Debian, but this time it overwhelmed me.

My first try happened in summer this year, but I surrendered. I managed to upgrade some of the packages, but most of them (over a thousand) remained not upgraded. You can see my earlier "findings" here: https://unix.stackexchange.com/a/596078/447111

I tried today, but failed again. Currently # apt-get dist-upgrade results in: 1013 upgraded, 380 newly installed, 129 to remove, 8 not upgraded. The 129 packages to be removed include kde-runtime (and some other KDE-related), nvidia-driver (and related), python and a lot of lib packages, which is unacceptable.

I have searched the web again and the problem seems to be quite common, yet there are no official fixes or workarounds. Some people say remove gcc-8 (https://prodevsblog.com/questions/690521/full-upgrade-to-debian-testing-fails-due-to-libc6-dev-breaks-libgcc-8-dev/), others say install gcc-8-base (https://www.reddit.com/r/debian/comments/h878ci/fullupgrade_to_debian_testing_fails_due_to/) etc., but none worked for me. One guy says that the problem is related to gcc-10 and renaming some of the packages. But I seem to have the *-s1 packages installed already, hence the problem might be somewhere else? Anyway, I am not skilled or persistent enough to dig deeper into this kind of stuff (tracking renamed packages) on my own.

I have no idea what the real problem is. Maybe there are many reasons or the complexity depends on which packages one has installed in their system. I have lost any hope and the only solution I see is to format the system partition and install a fresh bullseye or wait until it becomes stable and hope the devs will fix the issue by then. Unless somebody here helps me, please. :)

Maybe this will help you find the solution:

# dpkg -l gcc-* libc*dev libgcc*
ii  gcc-10-base:amd64    10.2.1-1     amd64        GCC, the GNU Compiler Collection (base package)
ii  gcc-10-base:i386     10.2.1-1     i386         GCC, the GNU Compiler Collection (base package)
un  gcc-4.3              <none>       <none>       (no description available)
un  gcc-4.4              <none>       <none>       (no description available)
un  gcc-4.5              <none>       <none>       (no description available)
un  gcc-4.6              <none>       <none>       (no description available)
ii  gcc-8-base:amd64     8.3.0-6      amd64        GCC, the GNU Compiler Collection (base package)
ii  gcc-9                9.3.0-19     amd64        GNU C compiler
ii  gcc-9-base:amd64     9.3.0-19     amd64        GCC, the GNU Compiler Collection (base package)
un  gcc-9-doc            <none>       <none>       (no description available)
un  gcc-9-locales        <none>       <none>       (no description available)
un  gcc-9-multilib       <none>       <none>       (no description available)
un  gcc-doc              <none>       <none>       (no description available)
un  gcc-multilib         <none>       <none>       (no description available)
un  gcc-x86-64-linux-gnu <none>       <none>       (no description available)
ii  gcc-10-base:amd64   10.2.1-1     amd64        GCC, the GNU Compiler Collection (base package)
ii  gcc-10-base:i386    10.2.1-1     i386         GCC, the GNU Compiler Collection (base package)
ii  gcc-8-base:amd64    8.3.0-6      amd64        GCC, the GNU Compiler Collection (base package)
ii  gcc-9-base:amd64    9.3.0-19     amd64        GCC, the GNU Compiler Collection (base package)
un  libc-dev            <none>       <none>       (no description available)
un  libc0.1-dev         <none>       <none>       (no description available)
un  libc0.3-dev         <none>       <none>       (no description available)
ii  libc6-dev:amd64     2.28-10      amd64        GNU C Library: Development Libraries and Header Files
un  libc6.1-dev         <none>       <none>       (no description available)
un  libcurl4-gnutls-dev <none>       <none>       (no description available)
ii  libgcc-9-dev:amd64  9.3.0-19     amd64        GCC support library (development files)
ii  libgcc-s1:amd64     10.2.1-1     amd64        GCC support library
ii  libgcc-s1:i386      10.2.1-1     i386         GCC support library
un  libgcc1             <none>       <none>       (no description available)
un  libgccjit-9-dev     <none>       <none>       (no description available)

EDIT (October 31, 2021)

Bullseye has been released as stable version, but I still cannot upgrade to it. During the last year I haven't really tried to solve it, but running apt-get upgrade from time to time allowed me to upgrade some (few) packages, probably those unaffected by the issue.

Here is the updated list of currently installed gcc-related packages:

ii  gcc-10-base:amd64    10.2.1-6     amd64        GCC, the GNU Compiler Collection (base package)
ii  gcc-10-base:i386     10.2.1-6     i386         GCC, the GNU Compiler Collection (base package)
un  gcc-4.3              <none>       <none>       (no description available)
un  gcc-4.4              <none>       <none>       (no description available)
un  gcc-4.5              <none>       <none>       (no description available)
un  gcc-4.6              <none>       <none>       (no description available)
ii  gcc-8-base:amd64     8.3.0-6      amd64        GCC, the GNU Compiler Collection (base package)
ii  gcc-9                9.3.0-22     amd64        GNU C compiler
ii  gcc-9-base:amd64     9.3.0-22     amd64        GCC, the GNU Compiler Collection (base package)
un  gcc-9-doc            <none>       <none>       (no description available)
un  gcc-9-locales        <none>       <none>       (no description available)
un  gcc-9-multilib       <none>       <none>       (no description available)
un  gcc-doc              <none>       <none>       (no description available)
un  gcc-multilib         <none>       <none>       (no description available)
un  gcc-x86-64-linux-gnu <none>       <none>       (no description available)
un  libc-dev             <none>       <none>       (no description available)
un  libc0.1-dev          <none>       <none>       (no description available)
un  libc0.3-dev          <none>       <none>       (no description available)
ii  libc6-dev:amd64      2.28-10      amd64        GNU C Library: Development Libraries and Header Files
un  libc6.1-dev          <none>       <none>       (no description available)
un  libcurl4-gnutls-dev  <none>       <none>       (no description available)
ii  libgcc-9-dev:amd64   9.3.0-22     amd64        GCC support library (development files)
ii  libgcc-s1:amd64      10.2.1-6     amd64        GCC support library
ii  libgcc-s1:i386       10.2.1-6     i386         GCC support library
ii  libgcc1:amd64        1:10.1.0+rp2 amd64        GCC support library (transitional package)
un  libgccjit-9-dev      <none>       <none>       (no description available)

And the output of dist-upgrade attempt:

# apt-get dist-upgrade
Reading package lists...
Building dependency tree...
Reading state information..
Calculating update...
The following packages were automatically installed and are no longer required:
  cracklib-runtime enchant fonts-dejavu fonts-linuxlibertine fonts-sil-gentium
  fonts-sil-gentium-basic freepats g++-9 gstreamer1.0-alsa
  gstreamer1.0-pulseaudio icoutils kate-data kde-runtime-data
  kde-style-qtcurve-qt5 kdelibs5-data libbctoolbox1 libboost-atomic1.67.0
  libboost-chrono1.67.0 libboost-date-time1.67.0 libboost-filesystem1.67.0
  libboost-iostreams1.67.0 libboost-locale1.67.0 libboost-system1.67.0
  libboost-thread1.67.0 libbrlapi0.6 libbsh-java libbzrtp0 libcfitsio7
  libcrack2 libcroco3 libdlrestrictions1 libdouble-conversion1 libdrm-dev
  libegl-nvidia-legacy-390xx0:i386 libegl-nvidia0:i386 libegl1-nvidia
  libegl1-nvidia-legacy-390xx:i386 libenchant1c2a libevent-2.1-6 libexiv2-14
  libfaac0 libffi6:i386 libflite1 libfluidsynth1 libgadu3 libgit2-27
  libgles-nvidia-legacy-390xx1:i386 libgles-nvidia-legacy-390xx2:i386
  libgles-nvidia1 libgles-nvidia1:i386 libgles-nvidia2 libgles-nvidia2:i386
  libgles2-mesa-dev libglvnd-core-dev libglx-nvidia-legacy-390xx0:i386
  libglx-nvidia0 libglx-nvidia0:i386 libgpgme++2v5 libgps23
  libgrantlee-textdocument5 libgraphene-1.0-0 libgssdp-1.0-3 libgssdp-1.2-0
  libgstreamer-plugins-bad1.0-0 libgupnp-1.0-4 libgupnp-1.2-0
  libgupnp-igd-1.0-4 libhogweed5 libhogweed5:i386 libhttp-parser2.8
  libice6:i386 libicu63 libicu63:i386 libigdgmm5 libigdgmm5:i386 libilmbase23
  libisl22 libjim0.77 libjson-c4 libjsoncpp1 libkaccounts1
  libkdecorations2private6 libkf5emoticons-bin libkf5emoticons-data
  libkf5emoticons5 libkf5jsembed-data libkf5jsembed5 libkf5libkdepimakonadi5
  libkf5xmlrpcclient-data libkf5xmlrpcclient5 libkwineffects11
  libkwinglutils11 libkwinxrenderutils11 liblept5 liblilv-0-0 libllvm7
  libllvm7:i386 liblouis17 liblouisutdml8 liblrdf0 libmeanwhile1
  libmjpegutils-2.1-0 libmms0 libmpdec2 libmpeg2encpp-2.1-0 libmplex2-2.1-0
  libmypaint-1.3-0 libnettle7 libnettle7:i386 libnice10 libntrack0
  libnvidia-eglcore:i386 libnvidia-glcore:i386 libnvidia-glvkspirv
  libnvidia-glvkspirv:i386 libnvidia-legacy-390xx-cfg1:i386
  libnvidia-legacy-390xx-eglcore:i386 libnvidia-legacy-390xx-glcore:i386
  libofa0 libokular5core8 libopenexr23 liborcus-0.14-0 libotr5 libperl5.28
  libplymouth4 libpoppler82 libpotrace0 libpwquality-common libpwquality1
  libpython2-stdlib libpython2.7 libpython3.7 libpython3.7-minimal
  libpython3.7-stdlib libqhull7 libqpdf21 libqtcurve-utils2 libraw19 libre2-5
  libreadline5 libreadline7 libreoffice libreoffice-avmedia-backend-gstreamer
  libreoffice-kde5 libreoffice-librelogo libreoffice-nlpsolver
  libreoffice-script-provider-bsh libreoffice-script-provider-js
  libreoffice-script-provider-python libreoffice-wiki-publisher librubberband2
  libruby2.5 libsane libsbc1 libserd-0-0 libsisu-guice-java libsisu-ioc-java
  libsm6:i386 libsnmp30 libsord-0-0 libsoundtouch1 libspandsp2 libsratom-0-0
  libsrtp2-1 libssh-gcrypt-4 libstdc++-9-dev libtesseract4 libtexlua52
  libtidy5deb1 libtss2-udev libturbojpeg0 libu2f-udev libusbmuxd4 libutempter0
  libvidstab1.1 libvo-aacenc0 libvpx5 libwildmidi-config libwildmidi2
  libx11-xcb-dev libx265-165 libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev
  libxcb-present-dev libxcb-randr0-dev libxcb-render0-dev libxcb-shape0-dev
  libxcb-sync-dev libxcb-util0 libxcb-xfixes0-dev libxdamage-dev
  libxshmfence-dev libxtst6:i386 libzbar0 libzimg2 mesa-common-dev
  ntrack-module-libnl-0 nvidia-driver-bin oxygen-icon-theme perl-modules-5.28
  phonon-backend-gstreamer-common polkit-kde-1 printer-driver-hpijs python2
  python2-minimal python3-sip python3.7-minimal
  qml-module-qtquick-controls-styles-breeze qtcore4-l10n ruby-did-you-mean
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  ffmpeg gstreamer1.0-plugins-bad kaccessible katepart kde-l10n-pl kde-runtime
  kde-style-breeze-qt4 kde-style-qtcurve-qt4 kdelibs-bin kdelibs5-plugins
  kdoctools kopete libattica0.4 libavdevice58 libavfilter7 libdbusmenu-qt2
  libegl1-nvidia:i386 libgl1-nvidia-glx libgl1-nvidia-glx:i386
  libgl1-nvidia-legacy-390xx-glx:i386 libgnustep-base1.26 libhfstospell10
  libkabc4 libkactivities6 libkatepartinterfaces4 libkcmutils4 libkde3support4
  libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4
  libkemoticons4 libkf5followupreminder5 libkf5kdepimdbusinterfaces5
  libkf5sendlater5 libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4
  libkldap4 libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4
  libknotifyconfig4 libkntlm4 libkopete4 libkparts4 libkpimidentities4
  libkpimkdav-data libkpimkdav5abi2 libkpimtextedit4 libkpimutils4 libkpty4
  libkresources4 libkrosscore4 libksgrd7 libksignalplotter7 libktexteditor4
  libldb1 libmediastreamer-base10 libmediastreamer-voip10 libnode64
  libntrack-qt4-1 libortp13 libphonon4 libplasma3 libpolkit-backend-1-0
  libpolkit-qt-1-1 libprocesscore7 libprocessui7 libpython-stdlib libqca2
  libqca2-plugins libqimageblitz4 libqjson0 libqt4-dbus libqt4-declarative
  libqt4-designer libqt4-network libqt4-opengl libqt4-qt3support libqt4-script
  libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-xml
  libqt4-xmlpatterns libqtcore4 libqtdbus4 libqtgui4 libqtwebkit4
  libreoffice-style-tango libsolid4 libtaskmanager6 libthreadweaver4
  libtss2-esys0 mariadb-client-core-10.3 mariadb-server-core-10.3
  nvidia-driver nvidia-driver-libs-nonglvnd nvidia-driver-libs-nonglvnd:i386
  nvidia-driver-libs-nonglvnd-i386:i386
  nvidia-legacy-390xx-driver-libs-nonglvnd:i386
  nvidia-legacy-390xx-nonglvnd-vulkan-icd:i386 nvidia-nonglvnd-vulkan-common
  nvidia-nonglvnd-vulkan-icd nvidia-nonglvnd-vulkan-icd:i386 phonon
  phonon-backend-gstreamer plasma-scriptengine-javascript python
  python-minimal python-parted python-talloc python3.7 qdbus qt-at-spi ruby2.5
  sni-qt uno-libs3 user-manager
The following NEW packages will be installed:
  alsa-topology-conf alsa-ucm-conf apt-config-icons-hidpi
  apt-config-icons-large-hidpi bup bup-doc cpp-10 dctrl-tools dvisvgm
  enchant-2 fonts-urw-base35 g++-10 gcc-10 gir1.2-gtksource-3.0
  glib-networking:i386 gstreamer1.0-plugins-good:i386
  gstreamer1.0-plugins-ugly gstreamer1.0-x:i386 hwdata ibus-data isolinux
  kmailtransport-akonadi kontrast kpeople-vcard kup-backup kuserfeedback-doc
  libaa1:i386 libabsl20200923 libaom3 libasan6 libatopology2 libavc1394-0:i386
  libavif9 libboost-filesystem1.74.0 libboost-iostreams1.74.0
  libboost-locale1.74.0 libboost-regex1.74.0 libboost-thread1.74.0 libbpf0
  libbrlapi0.8 libbrotli-dev libbrotli1:i386 libbz2-1.0:i386 libc-devtools
  libcaca0:i386 libcairo-gobject2:i386 libcfitsio9 libclone-perl libcrypt-dev
  libcrypt1:i386 libcuda1 libcuda1:i386 libcurl3-gnutls:i386 libcurl4:i386
  libdatrie1:i386 libdav1d4 libdav1d5 libdebuginfod1 libdeflate0
  libdeflate0:i386 libdouble-conversion3 libdv4:i386 libdvdread8 libdw1:i386
  libegl-mesa0:i386 libegl-nvidia-tesla-450-0 libegl-nvidia-tesla-450-0:i386
  libegl1:i386 libenchant-2-2 libevent-2.1-7 libexiv2-27 libfaudio0
  libfaudio0:i386 libfontbox-java libfontconfig-dev libfreetype-dev
  libfribidi0:i386 libgav1-0 libgbm1:i386 libgcc-10-dev libgdbm-compat4:i386
  libgdbm6:i386 libgdk-pixbuf-2.0-0 libgdk-pixbuf-2.0-0:i386
  libgdk-pixbuf-xlib-2.0-0 libgit2-1.1 libgl1-nvidia-tesla-450-glvnd-glx
  libgl1-nvidia-tesla-450-glvnd-glx:i386 libgles-nvidia-tesla-450-1
  libgles-nvidia-tesla-450-1:i386 libgles-nvidia-tesla-450-2
  libgles-nvidia-tesla-450-2:i386 libglx-nvidia-tesla-450-0
  libglx-nvidia-tesla-450-0:i386 libgnustep-base1.27 libgps28
  libgraphite2-3:i386 libgsettings-qt1 libgssdp-1.2-0 libgtksourceview-3.0-1
  libgtksourceview-3.0-common libgudev-1.0-0:i386 libgupnp-1.2-0
  libharfbuzz0b:i386 libhfstospell11 libhogweed6:i386 libhttp-parser2.9
  libicu67 libicu67:i386 libiec61883-0:i386 libieee1284-3:i386 libigdgmm11
  libigdgmm11:i386 libilbc3 libilmbase25 libip4tc2 libip6tc2 libjim0.79
  libjs-highlight.js libjson-c5 libjuh-java libjurt-java libkaccounts2
  libkcolorpicker0 libkdecorations2private7 libkdsoap1 libkf5authcore5
  libkf5dav-data libkf5dav5 libkf5kdegames7 libkf5pulseaudioqt2
  libkimageannotator-common libkimageannotator0 libkpmcore10 libksgrd9
  libksignalplotter9 libksysguardformatter1 libksysguardsensorfaces1
  libksysguardsensors1 libkuserfeedbackcore1 libkuserfeedbackwidgets1
  libkwaylandserver5 libkwineffects12a libkwinglutils12 libkwinxrenderutils12
  libldb2 liblibreoffice-java libllvm11 libllvm11:i386 liblouis20
  liblouisutdml9 libmarkdown2 libmd0 libmd0:i386 libmd4c0 libmpdec3
  libmypaint-1.5-1 libncursesw6:i386 libnettle8:i386 libnghttp2-14:i386
  libnode72 libnotificationmanager1 libnsl-dev libnsl2 libnsl2:i386
  libnspr4:i386 libnss-nis libnss-nis:i386 libnss-nisplus libnss-nisplus:i386
  libnss3:i386 libnvidia-ptxjitcompiler1 libnvidia-ptxjitcompiler1:i386
  libnvidia-tesla-450-cbl libnvidia-tesla-450-cfg1 libnvidia-tesla-450-cuda1
  libnvidia-tesla-450-cuda1:i386 libnvidia-tesla-450-eglcore
  libnvidia-tesla-450-eglcore:i386 libnvidia-tesla-450-encode1
  libnvidia-tesla-450-encode1:i386 libnvidia-tesla-450-glcore
  libnvidia-tesla-450-glcore:i386 libnvidia-tesla-450-glvkspirv
  libnvidia-tesla-450-glvkspirv:i386 libnvidia-tesla-450-ml1
  libnvidia-tesla-450-nvcuvid1 libnvidia-tesla-450-nvcuvid1:i386
  libnvidia-tesla-450-ptxjitcompiler1 libnvidia-tesla-450-ptxjitcompiler1:i386
  libnvidia-tesla-450-rtcore libokular5core9 libopenexr25 libopengl0:i386
  liborcus-0.16-0 liborcus-parser-0.16-0 libpango-1.0-0:i386
  libpangocairo-1.0-0:i386 libpangoft2-1.0-0:i386 libpci3:i386 libpdfbox-java
  libperl5.32 libperl5.32:i386 libphonenumber8 libphonon4qt5-data
  libpipewire-0.3-0 libpipewire-0.3-modules libplymouth5 libpoppler-cpp0v5
  libpoppler-glib8:i386 libpoppler102 libpoppler102:i386 libprimus-vk1
  libprimus-vk1:i386 libprocesscore9 libprocessui9 libprocps8 libprotobuf23
  libproxy1v5:i386 libpsl5:i386 libpython3.9 libpython3.9-minimal
  libpython3.9-stdlib libqhull-r8.0 libqpdf28 libqrcodegencpp1
  libqt5networkauth5 libqt5qmlmodels5 libqt5qmlworkerscript5
  libqt5quickparticles5 libqt5virtualkeyboard5 libraw1394-11:i386 libraw20
  libre2-9 libreoffice-kf5 libreoffice-plasma libreoffice-qt5
  libreoffice-sdbc-mysql libridl-java librtmp1:i386 libruby2.7 libsane1
  libsane1:i386 libshout3:i386 libsidplay1v5 libslang2:i386 libsnmp40
  libsnmp40:i386 libsoup2.4-1:i386 libsource-highlight-common
  libsource-highlight4v5 libspa-0.2-modules libsqlite3-0:i386 libssh2-1:i386
  libstb0 libstb0:i386 libstdc++-10-dev libtag1v5:i386 libtag1v5-vanilla:i386
  libtaskmanager6abi1 libthai0:i386 libtirpc-common libtirpc-dev libtirpc3
  libtirpc3:i386 libtss2-esys-3.0.2-0 libtss2-mu0 libtss2-sys1
  libtss2-tcti-cmd0 libtss2-tcti-device0 libtss2-tcti-mssim0
  libtss2-tcti-swtpm0 libtwolame0:i386 libudfread0 libuno-cppu3
  libuno-cppuhelpergcc3-3 libuno-purpenvhelpergcc3-3 libuno-sal3
  libuno-salhelpergcc3-3 libunoil-java libunoloader-java libunwind8:i386
  libusbmuxd6 libvmaf1 libvorbisidec1:i386 libwavpack1:i386
  libwayland-server0:i386 libx264-164 libx265-192 libxcb-res0 libxcb-util1
  libxcb-xinput0 libxstring-perl libxv1:i386 libz3-4 libz3-4:i386
  libzxingcore1 linux-compiler-gcc-10-x86 linux-headers-5.10.0-9-amd64
  linux-headers-5.10.0-9-common linux-image-5.10.0-9-amd64 linux-kbuild-5.10
  mailcap mariadb-client-core-10.5 mariadb-server-core-10.5 media-types
  nvidia-egl-common nvidia-settings-tesla-450 nvidia-smi
  nvidia-tesla-450-alternative nvidia-tesla-450-driver
  nvidia-tesla-450-driver-bin nvidia-tesla-450-driver-libs
  nvidia-tesla-450-driver-libs:i386 nvidia-tesla-450-egl-icd
  nvidia-tesla-450-egl-icd:i386 nvidia-tesla-450-kernel-dkms
  nvidia-tesla-450-kernel-support nvidia-tesla-450-smi
  nvidia-tesla-450-vdpau-driver nvidia-tesla-450-vulkan-icd
  nvidia-tesla-450-vulkan-icd:i386 nvidia-vulkan-common par2 partitionmanager
  pci.ids perl-modules-5.32 perl-tk pipewire pipewire-bin plasma-disks
  plasma-workspace-data primus-libs:i386 printer-driver-indexbraille
  printer-driver-oki psmisc pulseaudio-module-gsettings python3-distro
  python3-fuse python3-ldb python3-mutagen python3-parted python3-pycryptodome
  python3-pylibacl python3-pyqt5.sip python3-pyxattr python3-talloc
  python3-tornado python3-websockets python3.9 python3.9-minimal
  qml-module-gsettings1.0 qml-module-org-kde-kitemmodels
  qml-module-org-kde-ksysguard qml-module-org-kde-people
  qml-module-org-kde-prison qml-module-org-kde-quickcharts
  qml-module-org-kde-userfeedback qml-module-qt-labs-platform qml-module-qtqml
  qml-module-qtquick-particles2 qml-module-qtwebengine qtgstreamer-plugins-qt5
  qtspeech5-speechd-plugin rtmpdump ruby-rubygems ruby2.7 smartmontools
  systemd-timesyncd texlive-luatex tpm-udev uno-libs-private xkbset
  xserver-xorg-video-nvidia-tesla-450 xsettingsd yt-dlp
The following packages have been kept back:
  gstreamer1.0-libav libasound2-plugins libasound2-plugins:i386 libavcodec58
  libavcodec58:i386 libavformat58 libavresample4 libavresample4:i386
  libavutil56 libavutil56:i386 libchromaprint1 libk3b7-extracodecs libmfx1
  libpostproc55 libswresample3 libswresample3:i386 libswscale5 vlc-data
  vlc-plugin-base vlc-plugin-video-output
The following packages will be upgraded:
**(removed this list due to character limit)**
1046 upgraded, 376 newly installed, 126 to remove and 20 not upgraded.
Need to get 1 676 MB archives.
After this operation, 1 383 MB of additional disk space will be used.
Do you want to continue? [Y/n]
7
  • I have added Ryan Pavlik's repositories, but it didn't really change anything. running # apt-get upgrade let me to upgrade 4 packages: login, passwd, util-linux and util_linux_locales, but # apt-get dist-upgrade still wants to delete about 100 packages which I don't want to delete.
    – Leo
    Oct 31, 2021 at 15:03
  • The upgrade from Debian 10 to 11 was fixed before the release, Ryan Pavlik’s repositories are no longer necessary. You might be running into package removals related to the Python 2 cleanup... Oct 31, 2021 at 15:34
  • Fixed or not, I am stuck basically at the same point as last year...
    – Leo
    Oct 31, 2021 at 15:37
  • With the same gcc-10 problem? Oct 31, 2021 at 15:47
  • With the same gcc-10, gcc-8 or whatever package problem, yes. I have edited the original post as you requested.
    – Leo
    Oct 31, 2021 at 16:48

1 Answer 1

0

All your GCC-related issues appear to have been resolved.

The packages that are listed as being removed are mostly unsurprising:

That leaves ffmpeg, the gstreamer plugins, and most importantly for you I imagine, the NVIDIA drivers. The former are probably related to whatever is holding back the VLC upgrade. The latter appears to be related to the switch to Tesla drivers, but I don’t know what would cause that.

To make progress, you could try forcing partial upgrades of troublesome packages:

sudo apt install ffmpeg
sudo apt install nvidia-driver

At best this will work as-is, and upgrade the corresponding package sets; at worst, it should give you some more clues as to what exactly is going wrong.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.