0

Background Info

When I initially installed linux, I installed KDE and GNOME. I chose KDE as my default desktop environment and sddm as my window manager. KDE never worked (not sure why) so I have been using GNOME since and I am quite happy with it.

The Problem

However, when I configure startup applications, they appear to be starting as KDE applications. The system tray icons are the KDE variants, and when I open the program and hover over the window, the mouse switches from the usual GNOME pointer to the KDE pointer. I have to quit the applications and start them again to get them to run properly.

Here's the system tray on startup:

system tray before restarting

And after restarting the programs:

system tray after restarting

I have previously run into issues with CopyQ not running properly after booting the system, until I restart the program, and I think it might be related to this.

Interestingly, when I tried to take a screenshot using gnome-screenshot -p -d 5, the mouse in the screenshot was a gnome pointer.

What I Have Tried

I have changed the window manager to gdm3 and when I log in I choose GNOME xorg as my desktop environment.

I can't think of anything else I can change to fix this. Does anyone have any insight into what's going on here? And how I can fix it?

Any help would be greatly appreciated! Cheers!

1 Answer 1

0

Okay so I got there in the end!

For anyone out there what I did was completely uninstall anything related to KDE (sddm window manager etc.).

Then it turns out the icons being weird was to do with running X11. For some reason the icon wasn't scaling properly, so it was tiny. I've now switched to Wayland, for other reasons (per monitor scaling mainly), and although it has it's hindrances, it seems to handle scaling a lot better so that seems to be resolved.

Back to normal now, as far as normal goes in Debian with all the tweaks you make!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .