2

I recently bought new Bluetooth headphones (Jabra 75t) and have connectivity problems with my Lenovo x240 (Linux Mint 20). When I first connected the headphones, they connect in HSP/HFP mode, now when I manually switch to A2DP they immediately lose Bluetooth connection. When reconnecting everything, they reconnect in HSP/HFP and the audio quality is obviously quite bad.

Now I stumbled around and found when editing /etc/pulse/default.pa

.ifexists module-bluetooth-policy.so
load-module module-bluetooth-policy
.endif

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif

to

.ifexists module-bluetooth-policy.so
load-module module-bluetooth-policy ag=true
.endif

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover headset=ofono autodetect_mtu=yes
.endif

I do now have A2DP, but cannot use my Microphone any more, as the HSP/HFP profile is unavailable in PulseAudio. The Audio quality is quite great but I can only use the internal laptop microphone for voice calls.

Now ideally, I would like to have both good audio quality (A2DP) and use my microphone (HSP/HFP) but it seems like I have to edit /etc/pulse/default.pa to be able to switch between those two profiles.

Does anyone know any workaround or solutions? I'd be grateful for any advice or hint! If you need any further information, let me know!

1 Answer 1

1

That is something we would all like to have but A2DP gives good quality stereo sound but DOES NOT support mic at same time. As you already know the HSP/HFP sound is only mono and very poor to bad depending on your Bluetooth headset. I went through the same issue. Did you search this site there were lots of questions regarding this a few months ago. Here is my earlier question and the answers I got as well as the solution I found worked for me. Not a good solution but it works. Mono only blurtooth headset

1
  • Unfortunately, your workaround does not work for me. I do have to change the settings in /etc/pulse/default.pa as described above to activate my microphone.
    – cramx99
    Dec 16, 2020 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy