1

am using iTerm with Tmux, but I see this without tmux. If I hit SHIFT+SPACE I get the escape sequence ^[[32;2u. Is there a way to suppress it or disable that escape sequence? I am not seeing it in my preferences as a predefined escape sequence

2
  • 1
    The solution depends on the application that enables the xterm modifyOtherKeys feature. iTerm2 recently adapted/imitated/whatever this from xterm. – Thomas Dickey Dec 17 '20 at 22:08
  • Thanks @ThomasDickey, there ended up being a setting in iTerm called: Report modifiers using CSI u, disabling that worked! – Jamil Seaidoun Dec 17 '20 at 23:23
1

The solution depends on the application that enables the xterm modifyOtherKeys feature. iTerm2 recently adapted/imitated/whatever this from xterm.

The xterm manual in turn mentions a page in the FAQ XTerm – “Other” Modified Keys which gives information on the feature, and in that page's Other Programs section points to an iTerm2 discussion where Nachman added the CSI u feature in January 2019. That gives the same information as modifyOtherKeys, using a slightly different format (see formatOtherKeys, which dates from 2008).

Here's a screenshot showing the preference:

preference dialog from iTerm2

The "?" help points to iTerm2's website, which is a bit lacking in depth (ymmv). My intention when I developed the feature was that applications would enable it temporarily, rather than making the terminal turn it on indefinitely.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.