Trying to make a system update to upgrade Tensorflow:

sudo pacman -Syu

I am asked:

:: python-gast03 and python-gast are in conflict. Remove python-gast? [y/N]

I say No:

error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: python-gast03 and python-gast are in conflict

I then try to remove the oldest of the packages:

sudo pacman -R python-gast03

and I get:

error: target not found: python-gast03

So, where does this conflict come from if the oldest package is not even present?

  • it's asking if you want to remove python-gast, which means that's the one installed, and python-gast03 is the one it's trying to install
    – Fox
    Dec 15, 2020 at 17:29
  • OK. Since the one I am asked to remove is the most recent version, possibly needed somewhere else, can I install both? Is there an option for that which does not cause any issues down the road?
    – Pietro
    Dec 15, 2020 at 17:35
  • given that they are configured as "conflicts", no, you can't install both
    – Fox
    Dec 15, 2020 at 19:44

5 Answers 5


I had the same issue when updating my system.

sudo pacman -Syu

I tried removing python-gast.

sudo pacman -R python-gast

I was told that python-tensorflow-opt-cuda was dependent on that package. So, I updated it.

sudo pacman -S python-tensorflow-opt-cuda

It replaced gast with gast03 at that point. Then, I could do a system update.

sudo pacman -Syu

Everything worked as expected after that.


What worked for me was running

sudo pacman -R python-gast

and then updating whatever the dependency was.

In my case the command was

sudo pacman -S python-tensorflow

This will tell you that there is conflicts and give you an option to remove the outdated one.

and then you can run the update just fine.


I am on BlackArch.
I faced same issue, then I uninstalled python-gast and other dependencies along with it.
And then, I upgraded system and then reinstalled it.
Have a try?


Someone already made a bugreport for pacman:


Steps to solve the problem can be found in the report:

pacman -Sy python-tensorflow

pacman -Syu


I think it's because tensorflow was built on python-gast 0.3.x version. now python-gast updated to 0.4 version, but the new version of tensorflow still based on 0.3.x which was rename to gast03. So remove "python-gast(which will update to 0.4 version)" and update tensorflow(which will install python-gast03 automatically) would do the trick.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .