0

tldr I dual boot Mint 20 and Windows 10. EFI boot partition got corrupted so reformatted and re-installed Windows bootloader and grub. Windows works fine, grub menu displays, but can't boot into Mint and get a kernal panic error. I updated Mint last month but now re-installed grub from a USB with an older version of Mint, not sure if that's linked to the problem.


I have a dual boot with Mint 20 installed alongside Windows 10

I boot in UEFI mode and have a separate boot partition. This was corrupted somehow recently, I think because I had to hard-restart a few times in succession so Windows may have tried to do some recovery stuff which messed up the partition or something. As a result, I had to reformat the boot partition, re-install the Windows EFI boot loader and then re-install grub on that EFI boot partition using the method outlined here: https://linuxsuperuser.com/reinstall-grub2-efi-bootloader-ubuntu/

Note I also updated the UUID of the EFI partition in fstab after following those steps.

The grub menu successfully appears and I can get into Windows fine, but I can't get into Mint.

When I try to get into Mint, my Toshiba boot logo is displayed but nothing happens even after leaving it for 20 minutes.

When I choose to enter recovery mode from the grub menu it gives me a "kernel panic" error. Here is a photo I took of the errors that come up: https://imgur.com/a/21QKalO

I searched for this error and found a similar question: https://askubuntu.com/questions/71332/kernel-panics-with-cannot-open-root-device-error-where-do-i-append-the-root

The answer talks about many different things which to me seem like they should be irrelevant in my case since everything was working until I re-installed grub. What stood out to me in the answer though was this part:

"Check if the kernel that is being boot by the boot loader is the correct kernel. I have seen people who, after building a first kernel (which doesn't boot), forget that they have to mount /boot before the overwrite the kernel with a new one. As a result, they copy the kernel to the root file system (/) whereas the boot loader still expects the kernel image to be on the /boot partition."

I updated Mint about a month ago, but I installed grub from the original installation USB I used. So is it possible that grub is looking for the previous kernel when it should be look for the new one? I'm not sure what kernel my Linux installation was using, I'm quite new to Linux so I'm not sure how to find out.

If so, how do I remedy this?

Note fsck /dev/sda3 is fine. I tried the boot-repair GUI utility but when I click "recommended repair" nothing happens even if I wait 20 minutes. Pressing "quit" is unresponsive as well.

0

Fixed this by re-creating the initrd.img file in /boot.

For some reason the version of this file was different to the kernel version and I recreated it so they matched.

1
  • Would you elaborate how you re-create that? Also mention the different kernel version if possible. – Adi Prasetyo May 8 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.