0

I am trying to install pdo_sqlsrv in ubuntu 20.04 using https://serverpilot.io/docs/how-to-install-the-php-sqlsrv-extension/

When I try apt-get install unixodbc-dev I get:

The following packages have unmet dependencies:
 unixodbc-dev : Depends: unixodbc (= 2.3.7)
                Depends: odbcinst1debian2 (= 2.3.7) but 2.3.6-0.1build1 is to be installed
E: Problems could not be corrected, you have retained broken packages.

apt policy libodbc1:

libodbc1:
  Installed: 2.3.7
  Candidate: 2.3.7
  Version table:
 *** 2.3.7 500
        500 https://packages.microsoft.com/ubuntu/19.10/prod eoan/main amd64 Packages
        100 /var/lib/dpkg/status
     2.3.6-0.1build1 500
        500 http://ar.archive.ubuntu.com/ubuntu focal/main amd64 Packages

apt policy odbcinst1debian2
odbcinst1debian2:
  Installed: 2.3.6-0.1build1
  Candidate:  2.3.7
  Version table:
     2.3.7 500
        500 https://packages.microsoft.com/ubuntu/19.10/prod eoan/main amd64 Packages
 *** 2.3.6-0.1build1 500
        500 http://ar.archive.ubuntu.com/ubuntu focal/main amd64 Packages
        100 /var/lib/dpkg/status

Thank you

1
  • 1
    Please translate the messages to English. Dec 13 '20 at 1:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.