4

The wireless lan works, yet I have this log entries on journalctl -b -p 3. What is causing this?

Dec 11 21:26:09 raspberrypi wpa_supplicant[440]: Failed to initialize control interface '/run/wpa_supplicant'.
                                                 You may have another wpa_supplicant process already running or the file was
                                                 left by an unclean termination of wpa_supplicant in which case you will need
                                                 to manually remove this file before starting wpa_supplicant again.
Dec 11 21:26:09 raspberrypi NetworkManager[433]: <error> [1607718369.9284] sup-iface[0x2a0450,wlan0]: error adding interface: wpa_supplicant couldn't grab this interfac

cat /etc/wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US
network={
    ssid="foo"
    psk="bar"
}

1 Answer 1

8

You need to stop the NetworkManager service which use wpasupplicant.

sudo systemctl stop NetworkManager

kill all wpasupplicant instances:

sudo killall wpasupplicant

or

sudo killall wpa_supplicant

To disable the NetworkManager service completely use:

sudo systemctl disable NetworkManager
2
  • Disabled it completely using sudo systemctl stop NetworkManager
    – jjk
    Dec 12, 2020 at 11:14
  • 1
    I killed all wpa_supplicant processes, removed any configs related to wlan interface from /etc/network/interfaces or /etc/network/interfaces.d and then run sudo systemctl restart NetworkManager solved the issue. Aug 22, 2022 at 20:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .