0

I want to control my fan speed with fancontrol

My sensors are

$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +49.0°C  (high = +80.0°C, crit = +100.0°C)
Core 0:        +48.0°C  (high = +80.0°C, crit = +100.0°C)
Core 1:        +42.0°C  (high = +80.0°C, crit = +100.0°C)
Core 2:        +50.0°C  (high = +80.0°C, crit = +100.0°C)
Core 3:        +41.0°C  (high = +80.0°C, crit = +100.0°C)

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +27.8°C  (crit = +105.0°C)
temp2:        +29.8°C  (crit = +105.0°C)

nct6791-isa-0290
Adapter: ISA adapter
Vcore:                 880.00 mV (min =  +0.00 V, max =  +1.74 V)
in1:                     1.01 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
AVCC:                    3.36 V  (min =  +2.98 V, max =  +3.63 V)
+3.3V:                   3.34 V  (min =  +2.98 V, max =  +3.63 V)
in4:                   992.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in5:                   152.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in6:                   904.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
3VSB:                    3.33 V  (min =  +2.98 V, max =  +3.63 V)
Vbat:                    3.31 V  (min =  +2.70 V, max =  +3.63 V)
in9:                     1.01 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in10:                  152.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in11:                  128.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in12:                  128.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in13:                  128.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in14:                  128.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
fan1:                  1407 RPM  (min =    0 RPM)
fan2:                  1348 RPM  (min =    0 RPM)
fan5:                     0 RPM  (min =    0 RPM)
SYSTIN:                +117.0°C  (high =  +0.0°C, hyst =  +0.0°C)  sensor = thermistor
CPUTIN:                 +40.0°C  (high = +80.0°C, hyst = +75.0°C)  sensor = thermistor
AUXTIN0:                +31.0°C  (high =  +0.0°C, hyst =  +0.0°C)  ALARM  sensor = thermistor
AUXTIN1:               +111.0°C    sensor = thermistor
AUXTIN2:               +109.0°C    sensor = thermistor
AUXTIN3:               +110.0°C    sensor = thermistor
PECI Agent 0:           +40.0°C  
PCH_CHIP_CPU_MAX_TEMP:   +0.0°C  
PCH_CHIP_TEMP:           +0.0°C  
PCH_CPU_TEMP:            +0.0°C  
intrusion0:            ALARM
intrusion1:            ALARM
beep_enable:           disabled

I ran the pwmconfig generating the /etc/fancontrol

# Configuration file generated by pwmconfig, changes will be lost
INTERVAL=10
DEVPATH=hwmon0=devices/virtual/thermal/thermal_zone0 hwmon2=devices/platform/coretemp.0 hwmon3=devices/platform/nct6775.656
DEVNAME=hwmon0=acpitz hwmon2=coretemp hwmon3=nct6791
FCTEMPS=hwmon3/pwm5=hwmon0/temp1_input hwmon3/pwm1=hwmon2/temp1_input
FCFANS=hwmon3/pwm5=hwmon3/fan1_input hwmon3/pwm1=hwmon3/fan1_input
MINTEMP=40 hwmon3/pwm5=20 hwmon3/pwm1=20
MAXTEMP=60 hwmon3/pwm5=60 hwmon3/pwm1=60
MINSTART=150 hwmon3/pwm5=150 hwmon3/pwm1=150
MINSTOP=0 hwmon3/pwm5=100 hwmon3/pwm1=100

but when I run it I get

Loading configuration from /etc/fancontrol ...

Common settings:
  INTERVAL=10

Settings for hwmon3/pwm5:
  Depends on hwmon0/temp1_input
  Controls hwmon3/fan1_input
  MINTEMP=20
  MAXTEMP=60
  MINSTART=150
  MINSTOP=100
  MINPWM=0
  MAXPWM=255
  AVERAGE=1

Settings for hwmon3/pwm1:
  Depends on hwmon2/temp1_input
  Controls hwmon3/fan1_input
  MINTEMP=20
  MAXTEMP=60
  MINSTART=150
  MINSTOP=100
  MINPWM=0
  MAXPWM=255
  AVERAGE=1

Error: file hwmon3/pwm5 doesn't exist
Error: file hwmon3/pwm1 doesn't exist

At least one referenced file is missing. Either some required kernel
modules haven't been loaded, or your configuration file is outdated.
In the latter case, you should run pwmconfig again.

I checked my symlinks

$ ls -l /sys/class/hwmon
total 0
lrwxrwxrwx 1 root root 0 Dec 10  2020 hwmon0 -> ../../devices/virtual/thermal/thermal_zone0/hwmon0
lrwxrwxrwx 1 root root 0 Dec 10 09:47 hwmon1 -> ../../devices/platform/eeepc-wmi/hwmon/hwmon1
lrwxrwxrwx 1 root root 0 Dec 10 09:47 hwmon2 -> ../../devices/platform/coretemp.0/hwmon/hwmon2
lrwxrwxrwx 1 root root 0 Dec 10 09:47 hwmon3 -> ../../devices/platform/nct6775.656/hwmon/hwmon3

and

$ cat /sys/class/hwmon/hwmon*/name
acpitz
asus
coretemp
nct6791

I reran pwmconfig without success. How can I debug this issue? In one instance the fans changed speed but remained on maximum speed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.