5

IntelliJ IDEA shows this message on every startup.

image

How can I correct this warning on IntelliJ IDEA?

Edit: I installed IntelliJ IDEA ultimate edition by yay on arch linux.

3
  • 1
    I think you might want to post this one on a different space since this one is targeted for Linux stuff. For instance, how did you install IntelliJ IDEA? The .tar.gz wouldn't have that problem. You basically need to use the bundled JRE from IntelliJ IDEA, that's all.
    – x80486
    Dec 11, 2020 at 15:00
  • Thank you for commnet. I edited info to post. How can I switch to idea jre ? Dec 14, 2020 at 20:27
  • It's located in ${IDE_HOME}/jbr/. You would need to set an environment variable IDEA_JDK to that location — but I'm almost sure that's the default behavior, so you might want to consider the way you "installed" IntelliJ IDEA.
    – x80486
    Dec 14, 2020 at 20:36

2 Answers 2

3

On Arch Linux:

  • Install jdk-jetbrains from AUR.
  • put in ~/.bash_profile export IDEA_JDK=/usr/lib/jvm/jdk-jetbrains
5
  • If you show me how to export the path to fish I will accept your answer Mar 9, 2021 at 15:35
  • 1
    @JanČerný haha... add path temporarily... $ set -gx PATH $PATH <path> to set it permanently you have to write it in your config.fish which is usually at ~/.config/fish (if it exists, otherwise create it...) $touch ~/.config/fish/config.fish $ echo "set -gx PATH \$PATH <path>" >> ~/.config/fish/config.fish Apr 4, 2021 at 4:29
  • I did change it, exported in path and installed from aur and still get the message. What am I missing?
    – vfbsilva
    May 6, 2021 at 7:20
  • Is this really required?
    – SalahAdDin
    Aug 7, 2021 at 20:23
  • I added it to my .zshrc file and it didn't work.
    – SalahAdDin
    Aug 7, 2021 at 21:39
1

I can't comment yet, so I'll add to EnigmaCurry's answer here:

If the variable IDEA_JDK doesn't work, launch action search and select "Choose Boot Java Runtime for the IDE" to switch to the downloaded Java. The only weird thing is that the font settings are changed after this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .