Backstory: system is dual boot with UEFI running Windows 10 (originally Win7, but it forced an upgrade on me at some point) and Fedora: originally Fedora 28, but subsequently upgraded through to 32. This has all been happy and working for several years. However, in upgrading to 33 it got stuck and after a hard reset it wouldn't boot to Fedora anymore. For the life of me I could not get this system to successfully do the boot from a USB with live 33, so I went all the way back to my old Fedora 28 CD to reinstall from that.

I did the reinstall of F28. I used custom partitioning and gave it back all the old partitions. It forced me to reformat / but I was expecting that. I didn't reformat any of the other partitions. Then I updated 28 and attempted to upgrade to F32 (because I wanted to still have the F32 baseline to make sure various apps I use run).

Now it is in the state where the oldest F28 will boot (I think it is using old stuff from my original install based on timestamps) but the new stuff won't.

systemctl status boot-efi.mount complains that vfat is an unknown file system lsinitrd shows me that vfat is there, however

When I am booted to old F28, /boot/efi doesn't have subdirectories or anything, so symlinks to subdirectories are just junk, which I honestly don't comprehend. The /etc/fstab entry seems OK to me.

I've looked around a lot, and depmod -a doesn't help, secure_mode_insmod is already off.

I want to get to a point where I can boot to both Windows 10 and Fedora 33.

At this point I am really at a loss for where to look or what to try.


1 Answer 1


For the life of me I could not get this system to successfully do the boot from a USB with live 33

For me this would be the starting point thats needs to be solved. You say that your F28 was booted from an optical drive? But F33 fails from USB. Where does the boot process fail?

Disconnect the hard drives and boot with ONLY USB, try fedora 33 live. If you can boot like this, then possibly during boot the disk examination makes the system hang, a complete reinstall with repartitioning may help.

Make sure that this is not a problem with UEFI, maybe try without UEFI if you can disable it in the BIOS. I saw some scenarions where bios-disk-software combinations didnt work with uefi, but worked fine without.

if you get to the kernel selection but fail somwhere after, the try to get into the kernel arguments. Edit the kernel arguments, remove "rhgb quiet" and try to boot into single user mode, try to see if you get a root console eventually.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .