0

So I was following jays arch Linux installation tutorial on youtube, and after I installed the GRUB package, when I try to install GRUB, it gives me an error, here is a screenshot of that error! Thanks to whoever helps me in advance :D :)

Error

3
  • I suggest that you copy the text and paste it here, instead of a bad image of the text.
    – RalfFriedl
    Dec 7 '20 at 14:10
  • let me refer you to: unix.stackexchange.com/questions/91620/…
    – e.z.a
    Dec 7 '20 at 14:37
  • Lets see details, use ppa version with your live installer (2nd option) or any working install, not Boot-Repair ISO: Please copy & paste the pastebin link to the Boot-info summary report ( do not post report), do not run the auto fix till reviewed. help.ubuntu.com/community/Boot-Repair
    – oldfred
    Dec 7 '20 at 14:45
0

I solved it. The problem was that my PC was old and did not support efi. I had to do it in legacy mode like this -

pacman -S grub
grub-install /dev/sda --force

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.