1

I´m running pop os 20.04 lts in virtualbox version 6.1.16, and can not update virtualbox-guest-dkms-hwe. this is the error from popshop:

Error while installing package: installed virtualbox-guest-dkms-hwe package post-installation script subprocess returned error exit status 10

and in terminal i get this:

Loading new virtualbox-guest-6.1.10 DKMS files...
Building for 5.8.0-7630-generic
Building initial module for 5.8.0-7630-generic
ERROR (dkms apport): kernel package linux-headers-5.8.0-7630-generic is not supported
Error! Bad return status for module build on kernel: 5.8.0-7630-generic (x86_64)
Consult /var/lib/dkms/virtualbox-guest/6.1.10/build/make.log for more information.
dpkg: error processing package virtualbox-guest-dkms-hwe (--configure):
 installed virtualbox-guest-dkms-hwe package post-installation script subprocess returned error exit status 10
Errors were encountered while processing:
 virtualbox-guest-dkms-hwe
E: Sub-process /usr/bin/dpkg returned an error code (1)

can please somebody help me?

1 Answer 1

0

VirtualBox supports Linux kernel 5.8 starting with version 6.1.14. Current latest version is 6.1.16 and supports kernel 5.9. From Changelog:

VirtualBox 6.1.16 (released October 16 2020)

[...]

  • Linux host and guest: Support kernel version 5.9 (bug #19845)

[...]

VirtualBox 6.1.14 (released September 04 2020)

[...]

  • Linux host and guest: Linux kernel version 5.8 support .

The bug report for 6.1.10 with kernel 5.8 is there: #19644.

While you are using the main component in version 6.1.16 (on the host), you are trying to use version 6.1.10 of the kernel component (here on the guest), which is probably the only part affected by what's written above.

As it appears some packages you are using aren't even available in PopOS (but are in Ubuntu) you'll have to choose:

  • stick to stable 5.4 kernel rather than the hwe flavour

  • wait PopOS updates things (and lose the use of VirtualBox guest tools meanwhile).

  • use the PopOS staging repository which appears to include VirtualBox 6.1.14 which is enough to solve this:

    add-apt-repository "deb [arch=amd64] http://apt.pop-os.org/staging/master $(lsb_release -cs) main"
    

    currently (2020-12-07) providing 6.1.14 as seen there (don't download directly):

    http://apt.pop-os.org/staging/master/pool/focal/virtualbox/

    in case of doubt, add the repository, run apt update but not apt upgrade, install the newer version of the package and remove the repository.

  • as even PopOS's staging-ubuntu doesn't include 6.1.16 today, directly use the missing DKMS package (and only this one) from Ubuntu. As this will be anyway compiled from sources for this specific case, there won't be compatibility issues doing this. Don't install random packages from Ubuntu beside this one (and other source or dkms packages) or you might encounter random ABI compatibility issues.

    The Ubuntu groovy (20.10) DKMS package is currently version 6.1.16 and available from:

    https://packages.ubuntu.com/groovy/virtualbox-guest-dkms-hwe

You'll probably regularly encounter this kind of issue when a new kernel is out and VirtualBox and your distribution has to catch up.

2
  • Thank you!! Last option worked!
    – Bas
    Commented Dec 7, 2020 at 20:44
  • To thank me, you should accept this answer as a solution, since it worked.
    – A.B
    Commented Dec 7, 2020 at 22:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .