I noticed recently that shutting down my Linux (Ubuntu 20.04) desktop does not power it down once everything has come to a halt. It states Power down but the led is still glowing and the fan is still moving etc. which it shouldn't!

The result is a terminal stating as showin in the picture:

last lines of the shutdown process

I assumed something might be configured wrong in the BIOS but when I tried with Windows (I'm sorry!) it worked as usual so the problem seems to come from the linux side.

Of course I searched and tried other solutions like: Shutdown does not power off. Why?

However neither the KDE shutdown option nor the terminal call seem to work.

Another thing I tried was




but the answer seems outdated and does not work (anymore?). So even with the option

GRUB_CMDLINE_LINUX_DEFAULT="noplymouth intel_iommu=on acpi=force apm=power_off"

nothing happens (tried acpi=force and apm=power_off separately, too) and the computer still stays powered-on after shutting down.

One hint might be the output of acpi -V -i

No support for device type: power_supply

So is this the problem? Is there a way of configuring acpi correctly? Or did I miss something else?


  • File a bug report: bugzilla.kernel.org/enter_bug.cgi Commented Dec 6, 2020 at 11:14
  • Well first of all the question is: is this a bug or am I doing something wrong? Commented Dec 6, 2020 at 13:57
  • This surely looks like a bug only I can't say if it's a bug with your HW (e.g. BIOS) or kernel. Most likely it's down to your BIOS but there's a chance it's caused by the kernel. Commented Dec 6, 2020 at 15:09
  • But if it's the BIOS (UEFI) why does it work with Windows then? Aside from that it worked a while ago. I don't know if this came with the update to Ubunto 20.04 or so but it suddenly appeared. Commented Dec 6, 2020 at 15:27
  • Linux and Windows work with ACPI differently in subtle but critical ways. Commented Dec 6, 2020 at 15:31

6 Answers 6


I had the same problem as you had here with the same errors showing on the screen when I shut down or restarted the computer. I also tried all your solutions listed here. I use the internal GPU coming with the processor intel i7.

Then I find out that my computer shuts down properly only on Ubuntu 18 with the kernel version or (I can't remember properly). After updating the kernel version to any higher one will cause the same shutdown problem. Ubuntu 20 comping with 5.8. generic, so my computer never shuts down properly. I've tried to install an older kernel version, but I failed lots of times. Maybe you can solve the problem by installing an older version kernel successfully. I guess there is an inconsistency problem between Ubuntu and the hardware.

Finally, I gave up trying to solve this problem in Ubuntu 20 and switched to Fedora 33. My computer works perfectly on Fedora, although it has the kernel version of 5.11.


After installing windows 10 on a different partition I had the same issue. Even after removing windows and creating a new partition table in that drive didn’t solve the problem (I thought it could be something windows installer wrote to the drive’s MBR). All the linux distros on other drives and partitions couldn’t shutdown. Kernel instructions didn’t help either. What solved the problem was removing the motherboard battery before I went to work and after this reset to the BIOS/CMOS the problem was solved.


I had this problem on Dell XPS 15 9570 [GeForce GTX 1050 Ti Mobile] running Ubuntu 21.10 (stock, fresh install). I came across this thread during research on the problem.

I fixed it by removing noveau driver and installing nvidia drivers. I didn't need to mess with GRUB_CMDLINE_LINUX.


NVidia driver installed AND the optimus switch toggled to use them for me. No need to toggle anything else.

TongFang chassis with intel i7-9750H and TU116M [GeForce GTX 1660 Ti Mobile].


Install the NVIDIA drivers as per this link: https://docs.nvidia.com/datacenter/tesla/tesla-installation-notes/index.html#ubuntu-lts. Just tried it on my laptop with Ubuntu Server 22.04, and now it shuts down properly and reboots as well.

Make sure you apply sudo apt-get update and sudo apt-get upgrade -y afterwards to update the CUDA drivers package they have you install.

I did not have to do anything else.


I solved it by installing NVIDIA Proprietary Driver following https://wiki.debian.org/NvidiaGraphicsDrivers, kernel and legacy driver from backports. That resolved the poweroff issue. The reboot freeze was solved by GRUB_CMDLINE_LINUX="reboot=pci".

On laptop Asus K70IO (2009, NVIDIA GeForce GT 120M) freshly installed with Debian 10 Buster.

  • Thanks for the suggestion but I use my NVidia graphics board only for the VMs and the Intel GPU for Linux. So I'm not sure that's really the case here. Commented Dec 14, 2020 at 13:50
  • where would I add that? Commented Jun 21, 2022 at 12:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .