im using Kubuntu 20.10 with no tweaks.

mouse acceleration profile on system settings doesnt do anything. also mouse speed setting is weird. i set my mouse speed on windows as 720dpi and it is too fast on kde with level 2 speed, but level 1 is too slow. speed adjusting slider has too big range. i can tell changing mouse acceleration profile settings does somthing since mouse speed adjusting slider's range changes when i change profile.

i tried x11-related commands.

xinput set-prop <device> "libinput Accel Speed"

this changed speed but nothing else. and it is kinda broken like system settings.

xinput set-prop <device> "Coordinate Transformation Matrix"

only changes speed.

xinput set-prop <device> "libinput Accel Profile Enabled"

does nothing.

xset m <acceleration> <threshold>

does nothing.

i was on dirty system which is upgraded from customized kubuntu 18.04 to 20.04 so i tried with official kubuntu 20.04 live image but faced same issue. i have clean-installed kubuntu 20.10 but it didnt solved problem.


i checked some distributions:

  • Ubuntu 20.10
  • Lubuntu 20.10
  • Fedora (latest network install)

all of these are affected. im suspecting it is driver issue. i tried to test on Debian but i couldnt due to missing display driver. i thought further testing on other distribution is no longer needed since Fedora, away from widespread Debian-based systems, is affected. or this is just my issue?

1 Answer 1


Note that on the code side, in the Linux world "acceleration" is what everyone else would call "sensitivity". Getting actual mouse acceleration with libinput apparently requires defining custom acceleration profiles because its "adaptive" profile does hardly anything. So this is quite the hassle.

I would suggest switching the mouse driver to evdev which comes with multiple useful acceleration profiles (suggestion: go with their recommendation of "polynomial" (2))

Section "InputClass"
     Identifier "Logitech Gaming Mouse G400"
     MatchIsPointer "yes"
     Driver "evdev"

     Option "AccelerationProfile" "2"
     Option "VelocityScale" "3"
     Option "ConstantDeceleration" "10"
     Option "AdaptiveDeceleration" "1"

You can set the properties via cli using xinput. xinput uses the device property, also given in the documentation

edit: it bugged me so much that I dove into libinput acceleration profiles and wrote a user friendly GUI program to customize it. It's much more flexible than using udev.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .