Edit: I have installed CrunchBang (or #!, a Debian-based distro), and that seems to have solved all of my resolution problems.

I've just installed Debian after using Linux Mint for a few months.

Everything went on smooth, however, when the installation was over I noticed that the resolution was set really low.

I went to System > Preferences > Monitors, and that told me that the highest available resolution was 1024 * 768.

It also did not recognize my monitor properly as it was listed as "Unknown", the only rotation option was "Normal" and the refresh rate was "0 Hz" (although I'm having no problems with the refresh rate at the moment).

How can I get an optimal resolution (the native one)?

xrandr says:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 600, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768        0.0* 
   800x600        61.0 

lspci -v | grep VGA says:

00:02.0 VGA compatible controller: Intel Corporation Sandy Bridge Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller: ATI Technologies Inc NI Seymour [AMD Radeon HD 6470M] (prog-if 00 [VGA controller])

I'm not sure why there seem to be two graphics cards.

Currently I'm trying to install the non-free AMD/ATI r6xx r7xx drivers. Is this a good move? <- this changed nothing

I'm also missing the Xorg.conf file. <- As suggested I've created one, but that only made my computer unable to start displaying anything after Grub. I'll have to delete it from Ubunto.

If there's any more potentially useful info please tell me so I could share it.

  • 1
    You probably have one on-board graphics card (chip) on the motherboard, and another off-board graphics card (the ATI one). That would explain why you are seeing two, on separate buses (00 and 01, respectively).
    – user
    Jan 24 '13 at 8:59
  • 1
    You can use GRUB to add the parameter single at the end of the kernel command line. That will boot into single-user mode with only a minimum of services running. Particularly in your case, X will not be started. Then you can delete (or edit) your xorg.conf file to fix this non-functional X server problem.
    – user
    Jan 24 '13 at 9:01
  • @MichaelKjörling probably so. Could that be a (the) problem?
    – jcora
    Jan 24 '13 at 13:38
  • @MichaelKjörling, thanks for your device, but I had already fixed the problem. I booted to a Ubuntu LiveCD and deveted xorg.conf. Now it starts up just fine...
    – jcora
    Jan 24 '13 at 13:53
  • I doubt that having two graphics controllers is the source of your problem, but you can always try moving the graphics cable (the one between the monitor and the computer) from one connector to the other and see what happens. Worst case you'll have to move it back. (This can be done while the computer is up and running, if you are only a little careful when inserting the cable.)
    – user
    Jan 24 '13 at 15:04

Edit: I've found an actual solution that doesn't require you to install CrunchBang instead of Debian!

I was using Debian Squeeze, that used a kernel version that, apparently, did not support my graphics card.

The solution is simply upgrading to Debian testing (Wheezy).

Change your etc/apt/sources.list to:

deb http://ftp.hr.debian.org/debian testing main contrib non-free
deb-src http://ftp.hr.debian.org/debian testing main contrib non-free

deb http://ftp.debian.org/debian/ wheezy-updates main contrib non-free
deb-src http://ftp.debian.org/debian/ wheezy-updates main contrib non-free

deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

And then execute sudo apt-get update && sudo apt-get dist-upgrade.

Bam! Now you have a newer (and almost completely stable, as in, you probably wont experience any errors) version of Debian, which probably supports your card better than the older one.

Solution 2:

I have installed #! (CrunchBang) and all the problems were gone.

#! is pretty much Debian with some default configurations and Openbox by default.

  • I ran Ubuntu first and it worked fine, then when I switched to Debian I had the same problems stated in the question. Tried updating to Wheezy and it solved the problem for me as well :) Mar 12 '13 at 13:28

It's rare for for the monitor to not be auto-detected properly. Try making sure the appropriate drivers for your video card are installed, if you are using proprietary drivers, try using their utilities to generate the adequate xorg.conf file(s). Or you can try making a editing or creating one yourself. (Don't forget to change the driver to the one you are using.

Section "ServerLayout"
    Identifier    "layout1"
    Screen      0 "screen1" 0 0

Section "Monitor"
    Identifier  "monitor1"
    Option      "VendorName" "ACME"
    Option      "ModelName" "Generic Autodetecting Monitor"

Section "Device"
    Identifier  "videocard1"
    Driver      "nv" # change your driver here.

Section "Screen"
    Identifier "screen1"
    Device     "videocard1"
    Monitor    "monitor1"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth      24
            Modes      "1920x1080" "1280x720" "1024x768"

Add or remove the resolutions you want.

  • I'm trying to install the proprietary drivers at the moment, as I've heard that it could solve the problem. Also, I've put some new info into the question, please check it out.
    – jcora
    Jan 23 '13 at 21:38
  • Have you followed their wiki?
    – lmcanavals
    Jan 24 '13 at 6:09
  • I'm following it now but almost none of the tools they're using seem to be installed or even included in the repo. This is quite annoying.
    – jcora
    Jan 24 '13 at 14:15
  • It's rare for for the monitor to not be auto-detected properly. Nope! It's not rare at all. I have an EIZO L985EX attached to an older NVIDIA card (via DVI), and it turned out the culprit was nouveau. When I changed to proprietary nv driver (just for a test), my monitor was instantly detected correctly. nouveaucan still be horribly buggy at times (no wonder, it's reverse-engineered stuff) Sep 5 '13 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.