For the past two days, I have been attempting to install Linux Mint 14 64-bit edition.

Each time, the ubiquity installer has failed with this error:

Executing 'grub-install /dev/sda' failed.

This is a fatal error

At this point, a dialog box pops up asking me if I want to install the bootloader on a different drive or partition, continue without installing a bootloader or cancel the installation. I have three HDDs installed in my box--one SSD disk with Windows 7 on it, and two for storage and this Linux installation--and I have tried to install the bootloader on each one with resulting in the same error.

The rest of the installation is intact and I can see that the filesystem and structure is correctly installed. So, I googled a bit and turned up some people suggesting chroot into the installation and run grub-install from there. I did this and it returned an error message:

Path to `/boot/grub' is not readable by GRUB on boot. Installation is impossible. Aborting.

Help me solve this, please!

  • What the model of motherboard you have? – dchirikov Jan 23 '13 at 18:08
  • Can you post your partiton layout and the output of cat /boot/grub/device.map? – zje Jan 23 '13 at 21:10
  • @dchirikov GA-EP35-DS4 – b-vigilanT Jan 23 '13 at 22:14
  • @user825518 That file does not exist. Actually, I have solved this particular problem. GRUB managed to install once I set the mount point for /boot to my ext2 boot partition in the ubiquity installer. So, now my problem is that I am dropping into initramfs shell because grub cannot locate / on the encrypted root partition. Here's pic of the error message I get: imgur.com/c8aWZ6c – b-vigilanT Jan 23 '13 at 22:26
  • Your question dosen't mention encryption (or type), your partition scheme, or file system types, if you can provide this information it would help :) – arober11 Jan 24 '13 at 19:51

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.