0

I recently upgraded one of my machines from Fedora 28 (I think) to FC32 with XFCE4. After the update, my screen resolution is degraded to 640 x 480. Many items do not work at such a low resolution, because buttons falls outside the screen.

When I tried to change the Display Settings, the only selection for the resolution is 640x480.

There is no xorg.conf file that I can edit.

There is no "system-config-display" that I can use to generate one.

When I try to generate it by typing "Xorg -configure" I am told tht I must stop the X server first, but when I kill it, it respawns.

How do I resolve this? This works on my other Fedora systems ... just not this one.

7
  • what does xrandr -q say? If your system supports more than the resolution above, I might have a solution. But it could be that wayland is running... then xrandr won't work – kanehekili Nov 30 '20 at 20:52
  • "xrandr -q" says "Can't open display". – Lars Poulsen Dec 1 '20 at 21:10
  • I did eventually figure out to stop the X server and the XFCE login screen by entering "init 3", allowing me to create an xorg.conf file. – Lars Poulsen Dec 1 '20 at 21:11
  • Now that I have tried to fill in all the missing fields in that template xorg.conf file (and moving it to /etc/X11/xorg.conf) it fails to run. /var/log/Xorg.0.log says (among many other things) (EE) open /dev/dri/card0: No such file or directory (EE) Screen 0 deleted because of no matching config section (EE) Device(s) detected, but none match those in the config file. How do I find out what devices it had detected? – Lars Poulsen Dec 1 '20 at 21:13
  • Okay, so after I delete xorg.conf and start with all the default options, "xrandr -q" says: Screen 0 minimum 640x480, current 640x480, maximum 640x480 default connected 640x480+0+0 0mm x 0mm 640x480 0.00* That does not tell me anything I did not already know. – Lars Poulsen Dec 1 '20 at 21:49
0

Yes, your monitor supports more than 640x800, but the Xserver does not know the Monitor -obviously is does not sent you any EDID data, that the X-Server needs. In order to get a valid resolution you need to setup a conf file:

/usr/share/X11/xorg.conf.d/20-monitor.conf

At least this is the place, where I've put my config files. Since I do not know what hardware you have,I'd suggest to install xserver-xorg-video-intel and libdrm-intel1 (reading the error concerning dri). I wonder what you put into your conf file. I assume you configured the "device" section, but it looks the "Monitor" Section must be setup...

Maybe you could share the contents of your conf file... by adding it to your question

8
  • As I explained to begin with, there was no xorg.conf file The one generated by "Xorg -configure" had a video device "Card0" but when xorg started, it said there is no /dev/dri/card0 - which is true. My efforts have been trying to figure out what I could possibly put in the Display section, to define the video chip/card. The system in question is a SuperMicro rackmount server, and I think the Xorg server is using it in "generic quasi-VGA mode". The two packages you suggest do not exist on Fedora 32. I do, however, have packages named libdrm and xorg-x11-drivers-intel. – Lars Poulsen Dec 4 '20 at 20:12
  • Yes, you said so. But was wondering, what these "missing fields in that template xorg.conf file.." looked like. Usually there is no Xorg conf file in modern distros, but you always have the option to add one. I had to do it to get my nvidia card running. You did not mention what graphics you have (which would have helped) but I assumed you have an intel GPU.. Could you add the log in /var/log/Xorg0.log to your question? – kanehekili Dec 5 '20 at 16:40
  • The hardware is an ASPEED (ast) chip. The kernel seems to contain an ast driver, but I do not know how to get the system to load that instead of the "modesetting"driver, which I believe is a generic VGA driver - which should be okay, also. – Lars Poulsen Dec 8 '20 at 18:46
  • I cannot write a Device section for xorg.conf, because the kernel has not created a /dev/xxx device for the GPU. I cannot write a Screen section, because it is mandatory that it must point to a Device section. – Lars Poulsen Dec 8 '20 at 18:48
  • ASPEED provides a driver kit with RPMS but they are only for specific RHEL releases, and even the SRPMS are specific to those releases. – Lars Poulsen Dec 8 '20 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.