0

I have a server that is running Ubuntu 18.04 which had to be shut down. After reboot eth0 is not showing up when I run ifconfig or ip addr. Any ideas how to fix this?

The server is a backblaze storage pod 6.0 and it was shutdown due to planed maintenance of external power delivery and no hardware changes has been done to the machine itself.

The servers network is configured using netplan and running ip link set eno1 up response with Cannot find device "eno1" and the netplan configuration is as follows:

network:
  version: 2
  renderer: netowrkd
  ethernets:
    eno1:
      match:
        macaddress: INSERT_MAC_ADDRESS
      dhcp4: true
    eno2:
      match:
        macaddress: INSERT_MAC_ADDRESS_2
      optional: true 

Update: I tried running lspci and there the network card just not show up. Should I assume it is fried?

2
  • ifup eth0 has no effect?
    – Panki
    Nov 30, 2020 at 10:01
  • @Panki we use netplan, I have update the question accordingly Nov 30, 2020 at 10:10

1 Answer 1

0

Try booting with an older kernel. This may be caused by the proprietary NIC drivers which are not build with the latest kernel. You can also check if there are any available NICs with:

# lspci  | grep -E -i 'ethernet|network'
1
  • interesting thanks I will try and run this command Dec 1, 2020 at 7:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .