0

I know this question has been asked a couple of times however none of the answers seem to solve my issue. The problem is that the solutions provided somehow require internet connection before I can be able to run the command (i.e, the supposed solution) below and reboot;

sudo apt-get install --reinstall bcmwl-kernel-source
  • I have tried USB tethering with both WiFi and phone but it just doesn't work. I know it should because I've used it a couple of times but unfortunately it does not :(
  • I have also tried to update and install additional drivers from the Ubuntu software and updates program by using an ISO image stored in my home directory. It still doesn't work
  • Finally, I tried to manually download the package from the Ubuntu packages website then copy to my computer and install, this was also futile. [NOT RECOMMENDED]

Is there any other method available that may not require internet connection? really desperate...

Here is a link to a similar question: Ubuntu | No WiFi Adapter found

2
  • can you paste the result of the command sudo lspci | grep Network – Just Khaithang Nov 28 '20 at 7:28
  • yes, I saw this useful check online while troubleshooting earlier on. Unfortunately, I didn't save my output. Thanks, all the same – Mekky_Mayata Nov 28 '20 at 7:58
0

Finally found a fix for this.

  • I happened to have multiple versions of the kernel boot image in the /boot directory so I removed the current one and used a lower version to boot, then made necessary install and updates.

I think I was the cause of the problem because I remember randomly selecting lighter software packages to install when the software updater program popped up during my last session and somehow something broke. I was only trying to conserve data spent on installs :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.