0

I am trying to follow through with the answer to a problem (I have no internet on Ubuntu right now), but it is asking me to do USB tethering. I tried USB tethering with my Android phone, but it isn't working (it doesn't show up in ifconfig -a).

Here is a link to the answer: https://unix.stackexchange.com/a/423250

What does one do in this situation? It is a catch 22... I need internet in order to have internet...

I already looked around for help on USB tethering with Android, but nothing is working.

Is this the end of the road? Do I have to go back to Windows?

Also: I recently upgraded from Ubuntu 18 to 20.

Thanks in advance.

4
  • 1
    have you tried connecting with ethernet cable?
    – jsotola
    Nov 28 '20 at 0:00
  • @jsotola Yes. I have both an ethernet and wifi adapter. I tried with my ethernet cable. Also, my ethernet cable is tested (I used a testing device) and all the wires are straight, not crossed. What is weird is that it works perfectly fine when I booted to the Ubuntu 20 live USB instead of my SSD with the problem.
    – a135
    Nov 28 '20 at 0:03
  • This may sound like a silly response, and you may have already thought of it, but ... are you sure your Android device allows USB tethering, and that your mobile carrier allows it as well? And is USB tethering enabled in your device's settings? I know that when I connect my phone (Google Pixel 3a, Android 11) to my Linux system for tethering, the phone sets the USB connection by default to "Charge Only", and I get a notification that lets me change the mode to USB tethering (and a network interface then suddenly appears on the computer).
    – patbarron
    Nov 29 '20 at 3:20
  • Also if your immediate need is any connectivity, you should follow on the Ethernet connection track: since it's working from a live USB OS, it's likely to be easier to solve. You might be missing a firmware for the device or something like this. Basic knowledge on how to configure network with low level commands (ip link, ip address, ip route) and what dhcp client is already installed and how to run it if needed (dhclient, dhcpcd, udhcpc ...) should help.
    – A.B
    Nov 29 '20 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.