I have built an embedded system, originally it was on a PC based board, but I more recently moved it to a jetson nano. I started with NVidia's ubuntu 18.04 image, removed the desktop and replaced it with my software. My software expects that USB devices will not be mounted until I explicitly mount them.

I searched for ways of disabling automounting, most of the answers suggested it was the responsibility of the desktop, but I was no longer running the desktop. Some suggested it was the responsibility of udisks but I removed that and the automounting kept happening. I also removed nautilus in case that was somehow still doing the mounting despite the fact gnome was no longer running but that also made no difference.

How do I disable automounting on a system runing the NVIDIA 18.04 Ubuntu image?

1 Answer 1


After doing some grepping in /etc it looks like nvidia enabled automounting using a custom udev rule. /etc/udev/rules.d/99-nv-ufs-mount.rules

After removing that file automounting stopped.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .