1

I am trying to access the files on my NAS within programs and so I want to mount the network share.

When using the line:

sudo mount -t cifs -o username=correctusername,password=correctpassword,sec=ntlm,vers=3.0 //192.168.0.9/home /home/pi/data

I get the error:

mount error(2): No such file or directory

I have tried different secs, different verss and different share names. I am not fully sure what share to use but I think it is home. The Synology NAS is set to use version 2 to version 3 of SMB.

I can access the drive in the file explorer (Openbox I think) under Go -> Network. After going through two password checks, the address bar shows this: smb://data.local/home on data.local

I have tried quite a few things but I don't have much familiarity with Linux. Looks like same problem (unsolved) as here: mount error(2): No such file or directory - CIFS - Rasperry Pi

3
  • 1
    If it's your NAS, then do you not remember what the share was? If you don't, have you gone into the NAS to verify? – Nasir Riley Nov 28 '20 at 2:50
  • @NasirRiley I've tried using the names of the Shared Folders in DSM control panel. If that's not right, I don't know wher to find the share name. – user4913118 Nov 29 '20 at 18:53
  • It's your own NAS. Log into it and find out what the share names are. Until then, there's nothing that anyone can do to help you. – Nasir Riley Nov 29 '20 at 19:10
1

I fixed it. I think the combination of sec=ntlm,vers=3.0 was causing issue. Running dmesg showed:

[ 2938.581371] CIFS VFS: Unable to select appropriate authentication method!
[ 2938.581377] CIFS VFS: \\192.168.0.9 Send error in SessSetup = -22
[ 2938.581408] CIFS VFS: cifs_mount failed w/return code = -2    

I changed to vers=3.0,sec=ntlmv2 and got mount error(13): Permission denied so had to connect with an account that had higher permissions, which wasn't necessary when connecting over Windows or in the file browser, so it's not ideal, but works.

1
  • Hey, welcome to StackExchange! Thanks for taking the time to write up an answer to your own question; sadly, not everyone does this. Please mark your answer as "accepted", so readers can easily spot it. – Alexander Batischev Nov 29 '20 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.