0

I tried to install cuda on Manjaro with kernel linux54 and linux59 but did not manage to get it work. I have a 64-bit laptop with Hybrid graphics, my graphic card being a GeForce 950M. My video-driver is video-hybrid-intel-nvidia-450xx-prime (I don't think this has an impact though). The nvidia packages/drivers I have are:

> pacman -Qqe | grep nvidia
lib32-nvidia-450xx-utils
linux54-nvidia-450xx
linux59-nvidia-450xx
nvidia-450xx-utils
nvidia-prime

Here's what I got from nvidia-smi:

Fri Nov 27 13:46:47 2020       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 450.80.02    Driver Version: 450.80.02    CUDA Version: 11.0     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  GeForce GTX 950M    Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   43C    P8    N/A /  N/A |      3MiB /  2004MiB |      0%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A       797      G   /usr/lib/Xorg                       3MiB |
+-----------------------------------------------------------------------------+

Furtermore, here's the cuda version I have:

> pacmcan -Q cuda
cuda 11.0.3-1

Finally, here's what I get when running the deviceQuery sample from cuda:

> ./deviceQuery
./bin/x86_64/linux/release/deviceQuery Starting...

 CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 999
-> unknown error
Result = FAIL

I've seen several articles/posts indicating that CUDA was not supported by kernel 5.9 but they're all from October 2020, and NVIDIA was planning a working driver for 5.9 by mid-November. However, I did not find any posts indicating that the problem was solved. Do I merely need to wait for the nvidia-driver, or is my problem due to something else?

1

NVIDIA drivers 455.45.01 fully support kernel 5.9. The ones you're using don't support this kernel version.

Please update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.