I am trying to use xfce-screenshooter to take screenshot and save it to clipboard. Like this:

xfce4-screenshooter --region --clipboard

but when I try to paste it, there is no image. Thought it was caused by xfce-screenshooter itself. But I tried also flameshot, lightscreen and gnome-screenshot and all of them have same problem.

How can I diagnose and fix this problem ?

Thank you for your help

2 Answers 2


I'm not sure if this counts as a solution since it seems like a bit of a workaround. However, it worked for me.

Instead of using xfce4-screenshooter's clipboard option directly, use a clipboard manager like xclip.

For example:

xfce4-screenshooter -rs /dev/stdout | xclip -selection clipboard -type image/png

At that point I think I would prefer to use maim, since usage like this is specifically outlined by its man page


The solution above is now outdated, due to -type option being replaced with -t.
Now, the command is:

xfce4-screenshooter -rs /dev/stdout | xclip -selection clipboard -t image/png

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.