1

I've got a new monitor, 5120x1440, but I can't make it work.

I use OpenSUSE Tumbleweed, but I don't even know if it's distribution related or not.

When I set the resolution with this command: xrandr --output HDMI-0 --mode 5120x1440

this happens:

enter image description here

I had to take a picture with my phone because if I take a screenshot it looks normal.

I've tried several xrandr commands, I've tried both the hdmi port and the display port.. it always looks like this..

I tried to look online for it, but I don't even know how to call it.. Any idea?

Thanks


Here some more informations:

$ cat /etc/os-release 
NAME="openSUSE Tumbleweed"
# VERSION="20201123"
ID="opensuse-tumbleweed"
ID_LIKE="opensuse suse"
VERSION_ID="20201123"
CPU: 8-Core AMD FX-8320E (-MCP-) speed/min/max: 1396/1400/3200 MHz Kernel: 5.9.8-2-default x86_64 Up: N/A
Mem: 6318.9/15957.4 MiB (39.6%) Storage: 931.51 GiB (62.3% used) Procs: 330 Shell: bash 5.0.18 inxi: 3.1.00
Graphics:  Device-1: AMD Curacao XT / Trinidad XT [Radeon R7 370 / R9 270X/370X] vendor: Tul driver: radeon 
           v: kernel bus ID: 01:00.0 chip ID: 1002:6810 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: ati,radeon 
           unloaded: fbdev,modesetting,vesa resolution: 1: 2560x1440~60Hz 2: 2560x1440~60Hz s-dpi: 96 
           OpenGL: renderer: AMD PITCAIRN (DRM 2.50.0 5.9.8-2-default LLVM 11.0.0) v: 4.5 Mesa 20.2.2 
           direct render: Yes 
6
  • What's your (i)GPU? Kernel version? Distro? Please post xrandr output. Can you append -depth 16 to your X.org starting arguments and see if it helps or use DefaultDepth 16 in xorg.conf? Nov 26, 2020 at 0:45
  • Hi, I've added some more info to the question. I also tried DefaultDepth 16, but kde doesn't start, it get stuck like this imgur.com/a/osgRjUd, and ctrl+alt+fX don't work, so I can't even switch to a terminal to reboot.
    – Syco
    Nov 26, 2020 at 14:15
  • File a bug report here: gitlab.freedesktop.org/drm/amd/-/issues Add as much info as possible. Forget about the 16bit display depth hack ;-) Nov 26, 2020 at 19:52
  • I've logged it there, it's not being lucky on this.. gitlab.freedesktop.org/drm/amd/-/issues/1387
    – Syco
    Dec 2, 2020 at 13:03
  • Keep on trying: you're now talking to developers who are the only people who can really help you. Kernel drivers bugs are unlikely to be solved the the folks from this website. Dec 2, 2020 at 13:19

1 Answer 1

0

Okay so i've just got a 27 inch screen it's an XUB2792UHSU-B1 27 Inch with a native screen resolution of:

3840x2160

I've got the same issue, both console and in Xorg is see pixelated "corruption" of text, just like your image. The same problem with 1920x1080.

If i turn the video down to 1440x900 it's crystal clear, but as soon as i turn it back up again using xrandr, the problems start.

After some googling, I saw a site that said that dvi was only really meant to support upto 1920x1200 resolution, unless it's a dual link dvi cable, then it can support higher.

As if three flavors of DVI are not confusing enough, it turns out that DVI-D and DVI-I also come in either Single Link or Dual Link. The basic difference is that dual link can support higher resolutions. Single link cables can be identified as having 8 pins missing, while dual link cables use all 24 pins.

Single Link: Can support resolutions up to 1920 x 1080 at 60 Hz. Each link has three data channels for RGB information with a maximum bandwidth of 165 MHz, which is equal to 165 million pixels a second. Uses 12 of 24 pins. This is more than adequate for most plasma TVs. A typical DVI digital single link cable can be seen here: DVI digital single link cable

Dual Link: Can support resolutions up to 2048 x 1536 at 60 Hz. Each link has three data channels for RGB information with a maximum bandwidth of 165 MHz, which is equal to 165 million pixels a second. Uses all 24 pins. Here is a picture of a DVI digital dual link cable: DVI digital dual link cable

Source: https://www.cablewholesale.com/support/technical_articles/dvi_demystified.php

I'm using a GTX 710 graphics card, so i swapped out the dvi cable for a hdmi cable, and that's solved my console pixelation issue. The console text is now crystal clear. I wonder if i was using just a cheap DVI that was a single link dvi cable with connectors designed to look like dual link (but with the pins not connected to any wires internally)?

Now in your case, it might be that you need to use DisplayPort or something to drive that screen resolution. I see from other posts that your GPU does actually have a DP socket.

In terms of what to call this, it looks like it's trying to oversample video feed that is transmitting data too slowly or from a lower resolution, i think that's why you get the jumbled and highly aliased text fonts. It reminds me of the data you get through rs232 when the baud rate is set incorrectly (you get like stripes of missing bits). It's probably also why you don't see it in a screenshot.

In my case, with the graphics now working correctly, i was able to increase the terminal font size using:

dpkg-reconfigure console-setup

then set the font to terminus, then 16x32, this made the console font visible.

The next problem was when i started xorg using startx, the screen went black and the screen was reporting no signal, and powered itself off. Looking at the logs in:

~/.local/share/xorg/Xorg.0.log

I could see that Xorg was starting up with 3840x2180. With Xorg still running, I ssh'd in from a different system and ran:

xrandr -d :0

to dump out the available screen resolutions. Then i found one that looked promising and set it through ssh as follows:

xrandr -d :0 --output HDMI-1 --mode 1920x1080i

Then i went back down to the other room, checked my server screen and sure enough, i could see that there was graphics now being displayed and it was crisp and clear, so in the .xinitrc i added the xrandr before my window manager:

cat ~/.xinitrc 
xrandr --output HDMI-1 --mode 1920x1080i
exec wmaker

And now everything's working. Sure, i don't have the 3840x2160 resolution native to the screen, but this is fine for me, that's far too much resolution for me anyway (i got this screen for PIP / PBP functionality not screenres), however before i was unable to run at 1920x1080 because i'd get messed up text. Now I can see the text clearly.

Not sure if this helps for you, but maybe someone else comes across this problem is equally mystified. And I agree, this is not an easy thing to find on google.

In summary: Use display port for resolutions like you're using.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .