0

Sometimes the output from one compilation is longer than the lines my rxvt terminal seems to hold; can I increase that? If so, how?

I know I can redirect output to files for later inspection, but I'm interested in this scenario of outputting in the terminal.

This thread on ArchLinux forum seems to state there's no way to do that. Is it case?

0

1 Answer 1

1

The simplest way would be to start your rxvt using the -sloption: for example, rxvt -sl 50000 to have a scrollback buffer of 50000 lines. The default is 1000 lines, at least on my Debian system.

Assuming that you are using a modern Unicode-compatible version of rxvt, the way to make this persistent would be to edit (or create) a file named ~/.Xresources and add this line to it:

URxvt.saveLines: 50000

To make this setting effective, you'd need to logout & login again, or run this command in your current X session: xrdb -merge ~/.Xresources

This is a common mechanism for configuring classic X applications, known as X resources.

The thread you linked refers to increasing the scroll-back buffer on the text-mode virtual console i.e. when the X11 GUI is not running, which requires kernel modification.

1
  • Oh, so I was misunderstanding that post. Thanks!
    – Enlico
    Nov 25, 2020 at 17:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .