0

SSD drive has Linux and this other hard disk has 3 partitions. I can access two of these partitions, but for the remaining one I get the following error:

Error mounting /dev/sdb5 at /media/user_name/NewVolume: Unknow error when mounting /dev/sdb5

I have tried the command sudo ntfsfix /dev/sdb5 and success message was displayed in the terminal but the problem has not been solved.

1 Answer 1

1

If Windows has left a flag that this is a hibernated partition, then you won't be able to mount it as usual. Furthermore, using ntfsfix on such a partition can have some DANGEROUS CONSEQUENCES!

You could try to manually mount that filesystem in read only mode:

mkdir -p /tmp/sdb5
mount  -t ntfs-3g  -o ro  /dev/sdb5  /tmp/sdb5
cd /tmp/sdb5/
ls -la
2
  • after executing these commands, I've got, total 8 drwxrwxr-x 2 name name 4096 Nov 25 14:26 . drwxrwxrwt 21 root root 4096 Nov 25 14:26 .. Commented Nov 25, 2020 at 8:59
  • NTFS partitions are owned by root. And permissions when mounting control if you can use it or not. If hibernated from Windows, then data will be lost if you write from Linux and then Windows restores hibernation (deleting changes). Check Windows fast start up first, note that Windows updates will keep turning fast start up back on. And if that is off, then run chkdsk on that partition.
    – oldfred
    Commented Nov 25, 2020 at 14:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .