0

Trying to install docker on a VMWare guest CentOS 6 based on the documents of docker.

Upon running the script sudo yum install docker-ce docker-ce-cli containerd.io, it gives the message

https://download.docker.com/linux/centos/6/x86_64/stable/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"

checked the link https://download.docker.com/linux/centos/6/x86_64/stable/repodata/repomd.xml and it returns error 404. Checked the docker site and CentOS 6 is not on the list.

What I tried: Downloaded the docker repo and updated the baseURL to a mirror site.

[docker-ce-stable]
name=Docker CE Stable - $basearch
baseurl=http://mirror.centos.org/centos/6/os/x86_64/repodata/repomd.xml
enabled=1
gpgcheck=1
gpgkey=https://download.docker.com/linux/centos/gpg

then added it to my repo

sudo yum-config-manager \
    --add-repo \
    /home/username/Desktop/DOCKER PROJECT/docker-ce.repo

Tried to reinstall but got the message:

Repository '_home_username_Desktop_DOCKER': Error parsing config: Error parsing "baseurl = '/home/username/Desktop/DOCKER'": URL must be http, ftp, file or https not ""
2
0

On visiting to the repo of docker for centOs

https://download.docker.com/linux/centos/

you can see they don't have docker packages for Centos Version (7.0-7.9) and (8.0-8.9) there are no packages for any version 6 CentOs so its throwing 404 file not found error.

you can upgrade your centos to version 7 or 8 and follow steps given on https://docs.docker.com/engine/install/centos/ it will work well after that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.