1

So I have an Ubuntu bionic with mate desktop and I'm trying to remove the restart/logout options from the menu. At the moment I'm using the Brisk menu but could switch to anything else.

I already tried setting

  • gsettings set com.canonical.indicator.session suppress-logout-menuitem true
  • gsettings set com.canonical.indicator.session suppress-logout-restart-shutdown true
  • gsettings set org.mate.screensaver logout-enabled false
  • gsettings set org.mate.mate-menu.plugins.system_management show-logout false

but whenever I login, I still have the logout-option in the menu, not only in the Brisk menu, but any other too (mate, mate advanced...)

Moving/renaming gnome-session-quit and mate-session-save didn't help either.

This machine will be worked on via xrdp, and I want to prevent users from accidentally logging out since that messes up the service.

So anybody any idea?

0

/usr/share/glib-2.0/schemas/org.mate.lockdown.gschema.xml holds the key

disable-log-out

Setting this with gsettings to false will still leave the correspondent menuitems, but clicking on them will not do anything.

gsettings org.mate.lockdown disable-log-out true

To logout you'll then have to find the process id of the session and explicitly kill it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.