3

To build a virtual machine with GNOME Boxes, I have this problem: "virtualization extensions are unavailable on your system. Check your bios settings to enable them."

what's the solution?

0

2 Answers 2

3

To avoid this issue with GNOME Boxes, I had to configure Guix System to add my user account to the libvirt group and enable the virtlog and libvirt system services as below.

(operating-system
  ...
  (users (append (list (user-account
                         (name "me")
                         (comment "Me")
                         (group "users")
                         (supplementary-groups '("libvirt"))))))
  ...
  (services (append
              (list (service virtlog-service-type)
                    (service libvirt-service-type
                      (libvirt-configuration (unix-sock-group "libvirt"))))))
  ...
)

My user account is also a member of the kvm group so I can use guix system vm. This may also be required for GNOME Boxes - I haven't tested without it.

These tips were given to me by liberdiko on Guix IRC.

2
  • Thanks Ben, the problem is solved. More at issues.guix.gnu.org/44805
    – Pelian Pur
    Commented Nov 26, 2020 at 14:12
  • I confirm that adding kvm to supplementary-groups and rebooting (even after restarting libvirtd and virtlogd) was necessary too. Also, I added virtualization to use-service-modules declaration to make guix system reconfigure recognize those service types. Commented Feb 12, 2022 at 22:07
-1

go to your Computer BIOS and Enable VM !

1
  • 1
    The problem is here, it is active!
    – Pelian Pur
    Commented Nov 23, 2020 at 19:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .