Kinda shocked about supervisor. I get this error

unix:///var/run/supervisor.sock no such file

What is so shocking is the file is there! I am running on ubuntu on ec2. I tired to chmod to 0777 as well.

logfile=/var/log/supervisord.log ; (main log file;default $CWD/supervisord.log)
logfile_maxbytes=50MB       ; (max main logfile bytes b4 rotation;default 50MB)
logfile_backups=10          ; (num of main logfile rotation backups;default 10)
loglevel=debug               ; (log level;default info; others: debug,warn,trace)
pidfile=/var/run/supervisord.pid ; (supervisord pidfile;default supervisord.pid)
nodaemon=false              ; (start in foreground if true;default false)
minfds=1024                 ; (min. avail startup file descriptors;default 1024)
minprocs=200                ; (min. avail process descriptors;default 200)


files = *.supervisor
  • What raises this error? If it is supervisorctl, is supervisord already running?
    – sr_
    Jan 22, 2013 at 8:46
  • 1
    Did you ever get a resolution to this? I'm having a similar problem where supervisord won't start (in my case, /var/run/supervisor.sock is never created). Aug 7, 2014 at 13:45

3 Answers 3


I know this question is kinda old but for the sake of others who happen to land to this problem, starting the supervisor daemon works for me.

sudo service supervisor start

A more detailed explanation is that in general, when you encounter a "unix:///var/run/blabla.sock no such file" error, most likely the issue is that the daemon of the program in subject (supervisord in this case) wasn't started and thus wasn't able to generate the expected unix socket supervisor.sock file. This file is the communication endpoint for the supervisor foreground commands (such as supervisorctl) that acts as a tunnel/middleman responsible for relaying user-issued commands (ex. supervisorctl reread) to the supervisor service running in background.

You can refer to Unix Domain Socket and to this stackoverflow answer.


this was my problem, not sure if it helps. Aparently "service supervisord start" doesn't necessarily load your config file, or even a config file at all. In order to make mine work, I had to do a supervisord -c /path/to/my/config.conf (i.e. run the binary directly) this fixed everything.


I ran into this problem recently and I fixed it by following the following processes

  • 1). Activate your your virtualenv
  • 2). Ensure supervisor is install in your virtual environment with pip
  • 3). start supervisor as a superuser: $ sudo su
  • 4). run: $ supervisord or $ supervisorctl start

    And that's it.

    You must log in to answer this question.

    Not the answer you're looking for? Browse other questions tagged .