0

How reliable is the program lm-sensors in Linux? When I run watch sensors, I see large skips of temperature, as high as 10 degrees Celsius within the refresh interval of 2 seconds. The two readings below show this, with two screenshots taken 2 seconds apart, with Core 1 jumping 8 degrees down between those.

Reading 1:

Every 2.0s: sensors                                         Thu Nov 19 14:02:41 2020

iwlwifi_1-virtual-0
Adapter: Virtual device
temp1:        +66.0°C  

acpitz-virtual-0
Adapter: Virtual device
temp1:        +59.0°C  

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +67.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +61.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +67.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +60.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +59.0°C  (high = +100.0°C, crit = +100.0°C)

pch_skylake-virtual-0
Adapter: Virtual device
temp1:        +55.5°C 

Reading 2, taken 2 seconds later:

Every 2.0s: sensors                                         Thu Nov 19 14:02:43 2020

iwlwifi_1-virtual-0
Adapter: Virtual device
temp1:        +65.0°C  

acpitz-virtual-0
Adapter: Virtual device
temp1:        +61.0°C  

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +59.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +59.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +59.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +58.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +57.0°C  (high = +100.0°C, crit = +100.0°C)

pch_skylake-virtual-0
Adapter: Virtual device
temp1:        +55.5°C 

1 Answer 1

3

It's totally expected for new AMD and Intel CPUs due to their heat density due to very small transistors where billions of them are crammed into very small space.

If you don't want to see such high temperatures or temperature fluctuations, disable turbo boost:

echo 0 | sudo tee /sys/devices/system/cpu/cpufreq/boost

It might be different for Intel CPUs, please consult with https://askubuntu.com/a/620114

3
  • Thank you for the reply. Whenever I switch to my laptop's NVidia card (instead of the Intel) the temperatures rise substantially and fluctuate much more than before. Even at idle, they are often above 60 with random peaks reaching the high 60's, which is concerning for me. Would you be able to let me know how to disable turbo boost? Nov 20, 2020 at 11:53
  • 1
    I've updated the answer. Nov 20, 2020 at 12:28
  • 1
    Thank you. For future reference, in my system the option is actually located in /sys/devices/system/cpu/intel_pstate/no_turbo. This is a double negative, so a 0 means turbo is on and 1 means there is no turbo. Nov 20, 2020 at 13:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .