0

I read about transmission-cli and wanted to use it but I could not find out why my downloads did not work and I was wondering if it was set up the right way. I also had problems with authentication.

1 Answer 1

0

What you need to do is install it with

 sudo apt install transmission-cli transmission-daemon transmission-common

You can start the background process with transmission-daemon --no-auth and check if it works with transmission-remote -l. This should print an empty list of currently active torrents.

Note that this is insecure because you run it without authentication so everybody in the network could use the background process. But it is just for testing at this point.

You can add a torrent with -a, for example with the current Ubuntu image:

 transmission-remote -a https://releases.ubuntu.com/20.10/ubuntu-20.10-desktop-amd64.iso.torrent?_ga=2.98476063.1086280564.1605774166-1450607686.1605774166

If you check again with transmission-remote -l you will see the added link in the list. After a while the status should change from Idle to Downloading.

If you dont want to seed you can change the upload limits in the configuration file to 0 and set upload limit enabled to true. To change this configuration you have to sudo systemctl stop transmission-daemon before you edit it or the content will be overwritten. Start it again after editing with sudo systemctl. start transmission-daemon.

If your torrent client is working you can now start configuring it more accurately with the advice from here: https://www.smarthomebeginner.com/install-transmission-web-interface-on-ubuntu-1204/


Troubleshooting:

The service is in

/lib/systemd/system/transmission-daemon.service

I had to delete the following intermediate files to make the program load the current settings.json:

 sudo rm -R /var/lib/transmission-daemon

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .