I've been trying to run OpenVPN on Kali Linux using the official openvpn guide and ran the first command:

sudo apt update && apt -y install ca-certificates wget net-tools gnupg

Alls been updated and it seems the installation has gone well.

installed ca-certificates and net-tools

I run into an issue when I try to run the following:

sudo wget -qO - https://as-repository.openvpn.net/as-repo-public.gpg | apt-key add -echo "deb http://as-repository.openvpn.net/as/debian buster main">/etc/apt/sources.list.d/openvpn-as-repo.list

Permission Denied Error: OpenVPN Key Installation

I ran touch openvpn-as-repo.list to ensure the file has been created to echo to, but it seems this is not the fix.

It appears this requires explicit root privileges. Am I doing something wrong, or is there a kali repository I'm supposed to use for this?


To answer the question you need to run:

wget -qO - https://as-repository.openvpn.net/as-repo-public.gpg |sudo apt-key add -
echo "deb http://as-repository.openvpn.net/as/debian buster main" |sudo tee /etc/apt/sources.list.d/openvpn-as-repo.list

The openvpn package is available on kali repo, you don't need to add a third party repository, just run:

sudo apt install openvpn

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.