0

In Centos 8.2 I have configured a bridged wifi interface (ath9k) as a wireless access point in NetworkManager (nmcli). When using WPA or WEP security it works fine, but I need an open wifi network. I have scoured the internet and tried every 802-11-wireless-security setting in the NetworkManager documentation attempting to disable wireless security. Setting key-mgmt=none just enables WEP and I can't find any setting to disable WEP or wireless security in general.

I'm just looking for confirmation if this is possible to create an open wifi network without using another solution other than nmcli. If someone has done this I would be happy seeing their ..

$ nmcli con show wlan0
0
2

I found it is possible through a feature request to dev https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/issues/583#note_698098

Yes, you can create an open wifi network access point without implementing security protocols using nmcli and NetworkManager. Use the following command

nmcli connection add \
 type wifi \
 con-name "WLAN5G" \
 ifname wlp2s0 \
 autoconnect yes \
 wifi.mode ap \
 wifi.ssid "WLAN5G" \
 wifi.band a \
 wifi.channel 157 \
 ipv4.method shared \
 ipv6.method shared

Note the non-inclusion of any security parameters when creating the connection. Inclusion of security parameters when the connection is built creates a distinctly different connection profile which includes the 802-11-wireless-security section which will force WPA or WEP. Once a profile is formed sections can be removed but not added. i.e $ remomve 802-11-wireless-security So you may need two profiles if you want to switch between secure and insecure.

Along these same lines, folks are trying to bridge wifi to ethernet. You cannot change a wifi connection profile after it is created to include the bridge as it won't contain that section and you cannot add, so to create an open wifi bridged access point include the "master" parameter.

nmcli connection add \
 type wifi \
 master br0 \
 con-name "br0.WLAN5G" \
 ifname wlp2s0 \
 autoconnect yes \
 wifi.mode ap \
 wifi.ssid "WLAN5G" \
 wifi.band a \
 wifi.channel 157

After bridging wifi you may have difficulties with the wpa_supplication and may need to specify the bridge interface on the command line, systemd, or arguments file. For CentOS8 this was in /etc/sysconfig/wpa_supplicant

--INTERFACES=""
++INTERFACES="-i wlp2s0 -b br0" 

Not the answer you're looking for? Browse other questions tagged or ask your own question.