6

When I sync two folders between two HDDs, rsync only lists the changes made at the end.

However if I sync a folder between a HDD and an external HD, while the sync is running it is listing each directory where it gets in. So at the end I have a "dirty" log about tasks made and I have to be filtering it.

I would like to have a clean log also when syncing with the external HD, any idea?

I'm using -av --delete.

Examples where both directories are the same already:

  • HD to USB:

    rsync -av --delete A/ /media/USB/E/
    sending incremental file list
    ./
    B/
    B/C/
    B/D/
    
    sent 102 bytes  received 27 bytes  258.00 bytes/sec
    total size is 0  speedup is 0.00
    
  • HD to HD:

    rsync -av --delete A/ /media/DATA/E/
    sending incremental file list
    
    sent 90 bytes  received 15 bytes  210.00 bytes/sec
    total size is 0  speedup is 0.00
    
5
  • 1
    What filesystem are you using on the external drive? Is it FAT? It has poor timestamp resolution so probably rsync is seeing the different timestamp on the directory, and trying to update it.
    – psusi
    Jan 21, 2013 at 15:30
  • FAT32 (USB) and NTFS (external HD). Both HDDs are in EXT4. Jan 21, 2013 at 15:31
  • quick guess: permissions differs on FAT?
    – gelraen
    Jan 21, 2013 at 16:14
  • In the second example, nothing was copied. The data sent was just file list data for comparison.
    – jordanm
    Jan 21, 2013 at 16:53
  • Read what I said.. "Examples where both directories ARE THE SAME already". The second option is right, nothing has to be copied. The first one should be like the second, but it isn't, and that's what I'm asking about. Jan 21, 2013 at 16:57

2 Answers 2

2

rsync has got an option called --modify-window=NUM which you can use to reduce the accuracy of time-stamp comparison. Try it with --modify-window=1. The option was created for exactly this purpose.

rsync may also try to fix other metadata, like file ownership, which is lost on FAT32 and friends, so you may still have issues even when using --modify-window=1

0

Your USB fat32 partition doesn't handle all the metadata. Instead of -av try -rv.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.