3

I just installed OpenBSD on a sparc64 based pc but when I try to do pkg_add -v firefox it says can't find firefox. I also tried installing nano, which installed fine, so why can't it find firefox.

3
  • I haven't used OpenBSD in a while, but try pkg_add -v mozilla-firefox. I think you need to specify that it's mozilla-firefox? That's how it used to be, I'm pretty sure.
    – KGIII
    Commented Nov 17, 2020 at 3:15
  • Tried it but still doesn't work by typing mozilla-firefox. Commented Nov 17, 2020 at 3:17
  • Huh. That's changed, so I decided to use a search engine. It used to just install with mozilla-firefox, but now there's a giant thread about it here. How bizarre?
    – KGIII
    Commented Nov 17, 2020 at 3:23

1 Answer 1

5

The Firefox browser is available in the firefox or firefox-esr packages.

Unfortunately for you, neither of these can be built on the sparc64 architecture (they are for amd64, i386, and aarch64 only).

The port was marked "broken" for sparc64 in 2015:

Face reality, mark as BROKEN-sparc64. xpcshell SIGBUSes during fake, and nobody cares. No point in wasting hours during bulk builds.... If you want a graphical browser on sparc64, try netsurf.

The sparc64 build support for the browser was removed in 2016 with the comment

Remove the build goo for macppc|sparc64|alpha, it's unlikely this will ever come back...

The port was finally restricted to a small set of architectures in 2017:

Set ONLY_FOR_ARCHS properly - all the world is x86 anyway. Ditch --disable-debug-symbols on i386, it links fine without it.

An alternative web browser to try may be

All three of these are available as pre-built packages for the sparc64 architecture.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .