1

I have this issue in Ubuntu 20.04 (running under KDE desktop).

Whenever I plug a mouse to my computer, it does detect it, it appears on my xinput list, but it never works. OS keeps ignoring it. My xinput list would be like this:

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Asus Keyboard                             id=12   [slave  pointer  (2)]
⎜   ↳ ELAN1200:00 04F3:3045 Touchpad            id=14   [slave  pointer  (2)]
⎜   ↳ Compx 2.4G Receiver Consumer Control      id=20   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Asus Wireless Radio Control               id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Video Bus                                 id=9    [slave  keyboard (3)]
    ↳ Power Button                              id=10   [slave  keyboard (3)]
    ↳ Sleep Button                              id=11   [slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam: USB2.0 HD           id=13   [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=15   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=16   [slave  keyboard (3)]
    ↳ Asus Keyboard                             id=17   [slave  keyboard (3)]
    ↳ Compx 2.4G Receiver                       id=18   [slave  keyboard (3)]
    ↳ Compx 2.4G Receiver System Control        id=19   [slave  keyboard (3)]
    ↳ Compx 2.4G Receiver Consumer Control      id=21   [slave  keyboard (3)]

This happens whether the mouse is wireless or not, as I've already tried with a few different mice.

If I go to "Ignored devices" list in the "Enable/Disable M Touchpad" tab under "Touchpad -System Settings Module", my mouse appears there, but I find no way of remove it from that list. If I check the "Disable touchpad when mouse is plugged in" I just lose control over my touchpad and I have to enable it back from command line, but mouse does not work anyway.

I've been looking for some solution for a while and tried a few, but none of them seemed to address exactly the same problem and none of them worked for me.

What is your guess is the source of my problem here? How I can tell the system to stop ignoring pointers others than my touchpad?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.