1

On my Debian Buster I have a Samba share that works fine from both Windows and Linux clients. I've configured the Samba with min protocol = SMB2 in smb.conf and with local user/password authentication (no AD).

But I'm not able to connect to the share from neither my Brother network document-scanner nor my HP MFP (using CIFS). These devices connect fine to shares on Windows computers where SMBv1 is disabled (I assume SMBv2 must be used then).

If I remark min protocol = SMB2 on my Samba server they connect fine! Can it be anything else than a bad SMBv2 implementation on the devices? A firmware update to the HP printer didn't solve the problem.

Any suggestions are welcome :-)

UPDATE:

I started to read the smbd manual now :-/

I increased the log-level using log level = 5 in smb.conf, remarked n protocol = SMB2 and then did a scan-session. I can see in the log for the session (/var/log/samba/log.10.0.1.20) that it is actually using smb2_02. So I just need to dig a little more so see why it goes wrong when setting the mininum protocal level.

1

The manual says

By default SMB2 selects the SMB2_10 variant.

And I can see my HP MFP sent the request Requested protocol [SMB 2.002]

So I just had to use this option instead: server min protocol = SMB2_02

(FYI min protocol is a synonym of server min protocol)

And my Brother 2600W documents scanner is also using SMB 2.02 so it's also working now :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.