Running into a strange problem. I have a local server running Red Hat on a virtual machine (accessed through putty). I'm using this server to work on a website in Django, which I run with:

python manage.py runserver 8080.   

Now that works just fine, and I can access it through redHatIP:8080. However, I recently downloaded and installed Wordpress, Drupal, and Mint. Mint was added to the original site, and I access it through redHatIP/mint. Wordpress and Drupal are completely unrelated to the original site, but are both located in /var/www/html (long with the original site located through my 8080 poty).

I accessed drupal and wordpress through redHatIP/drupal and redhatIP respectively, and it was working just fine until today. For some reason when I go to redHatIP now I receive the following error in my internet browser:

The requested URL / was not found on this server.

If I go to redHatIP/drupal I received The requested URL /drupal was not found on this server, to redHatIP/anything I receive The requested URL /anything was not found on this server et cetera. This applies to Mint as well, which I access through redHatIP/mint. However, I can still access the original site through redHatIP:8080, and that works just fine.

I completely removed Django and wordpress, then downloaded them again. I tried having just one of them located in /var/www/html/, but that did nothing. I tried moving them to /var/www/, but that also did nothing.

When I go to my error log messages in /pwd/log/httpd/error_log It has the following message:

_default_ VirtualHost overlap on port 80, the first has precedence.

However this was reported the day before all this happened, when I had both Django and Wordpress together, and there hasn't been any message since.

I have been unable to fix this on my own, nor have I found a solution on the net. Any ideas? Any other information that would help understand the problem? et cetera?

  • There are a lot of details you left out here. When you say "could not access", what errors are you seeing? Perhaps you should take a look at your /var/log/httpd/error_log to see if there are any errors? – jsbillings Jan 20 '11 at 18:03
  • The only error messsages in error_log was because I had both wordpress and drupal in html: default VirtualHost overlap on port 80, the first has precedence. and sorry for the vagueness, and I worded that -really- poorly. When I go to redHatIP I see the following error message: The requested URL / was not found on this server. – Wipqozn Jan 20 '11 at 18:11
  • Sounds like you need to look at your apache configuration files and see what's changed in there. – David Mackintosh Jan 22 '11 at 2:17
  • Since it appears your question is related to servers, can you try serverfault.com? – tshepang Feb 4 '11 at 18:20
  • I've reformatted the question. Can you check if my edits are okay? – tshepang Feb 4 '11 at 18:23

Someone else working on the same server remotely made some adjusted to the httpd .conf files while he was on Vacation without notifying me. In var/etc/conf.d all the .conf files had their DocumentRoot set to the Drupal6 folder, instead of the Wordpress folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.