0

I'm trying to boot with esxi 7 the physical installation of arch linux,that I created on the disk /dev/sdc in efi mode,where sdc1 is the efi partition and sdc2 the root partition. In arch linux the PARTUUID number of sdc2 is : dae266be-16e9-41b1-bb07-1994c4541d06,as u can see below :

[root@zio ziomario2020]# ls -l /dev/disk/by-partuuid/


lrwxrwxrwx 1 root root 10 11 nov 2020 00796039-7a8f-4bad-8598-9c794ec9d8fa -> ../../sdc1

lrwxrwxrwx 1 root root 10 11 nov 2020 1967ba67-01 -> ../../sdb1

lrwxrwxrwx 1 root root 10 11 nov 2020 1967ba67-02 -> ../../sdb2

lrwxrwxrwx 1 root root 15 11 nov 2020 25ec0032-425b-4367-a61e-35570fee906b -> ../../nvme0n1p3

lrwxrwxrwx 1 root root 15 11 nov 2020 4502a2b7-2e6d-4435-92a8-67a9f823e9d2 -> ../../nvme0n1p1

lrwxrwxrwx 1 root root 15 11 nov 2020 7da95484-fa63-11ea-90be-8fd5c533639e -> ../../nvme0n1p5

lrwxrwxrwx 1 root root 15 11 nov 2020 7da95485-fa63-11ea-90be-8fd5c533639e -> ../../nvme0n1p6

lrwxrwxrwx 1 root root 10 11 nov 2020 a6e39599-01 -> ../../sda1

lrwxrwxrwx 1 root root 15 11 nov 2020 d3c74aeb-1937-4336-bf33-e0bfcc395e34 -> ../../nvme0n1p2

lrwxrwxrwx 1 root root 10 11 nov 2020 dae266be-16e9-41b1-bb07-1994c4541d06 -> ../../sdc2

lrwxrwxrwx 1 root root 15 11 nov 2020 eb97f56b-1828-4fb8-b9d7-7806a6720a41 -> ../../nvme0n1p4
 

[root@zio ziomario2020]# fdisk /dev/sdc -l


Disk /dev/sdc: 298,09 GiB, 320072933376 bytes, 625142448 sectors

Disk model: WDC WD3200AAJS-0

Units: sectors of 1 * 512 = 512 bytes

Sector size (logical/physical): 512 bytes / 512 bytes

I/O size (minimum/optimal): 512 bytes / 512 bytes

Disklabel type: gpt

Disk identifier: CCBAD042-80E0-47D1-835B-5B731895B6D3

 

Dispositivo Start Fine Settori Size Tipo

/dev/sdc1 2048 1050623 1048576 512M EFI System

/dev/sdc2 1050624 625141759 624091136 297,6G Linux filesystem

I haven't any problem to boot arch linux using the physical disk,but it does not work when I try to boot it using esxi 7,because it can't find the UUID of the partition,as u can see on the attached screenshot.

enter image description here

I have also tried to use the FS UUI that I got with the command : lsblk -f but it also didn't work :

enter image description here

Below u can see what is the command that I use to boot Arch with esxi :

enter image description here

enter image description here

Could someone give me some help to understand how can I fix the error ? very thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.