I have installed Fedora 18 with Gnome desktop and installed tigervnc-server. This same setup has worked fine with several other computers with Fedora 17, allowing me to do remote connections with TightVNC Viewer from a Windows machine. However with Fedora 18 I get an "Oh no. Something has gone wrong" message in the VNC Client when I try to connect. If I force Gnome to fallback mode then the remote session works fine. Fedora 17 uses Gnome 3.4.2 and Fedora 18 uses Gnome 3.6.2 so that may have something to do with it. The remote session also works with KDE desktop but not LXDE or XFCE.

I have not found any posts from others about this situation so I expect that I am missing something obvious. If someone has an idea or can point me to the posting regarding this that I missed it would be great.

  • I think it may just be a bug, especially because it works for you in fallback mode.
    – mattdm
    Commented Jan 20, 2013 at 18:50
  • Yeah, I was just surprised that I didn't find any other postings about it. Also I don't know if it is a Fedora bug or a Gnome bug. For now I am using Cinnamon-2d desktop which does work and is nicer (I think) than Gnome 2 and maybe Gnome 3 (it is growing on me). Commented Jan 22, 2013 at 3:53
  • Tried updating? Could be a plain bug...
    – vonbrand
    Commented Jan 29, 2013 at 16:12

3 Answers 3


This is bug 896648 in the Red Hat bugzilla. According to comment 15 you can fix it by:

  • Add -session optional pam_systemd.so to /etc/pam.d/runuser-l; the whole file should look like:

    auth            include         runuser
    session         optional        pam_keyinit.so force revoke
    -session        optional        pam_systemd.so
    session         include         runuser
  • Edit vncserver@:<display>.service

    • Change Type to simple
    • Add an -fg parameter to the vncserver command in ExecStart
    • Comment out the ExecStop line
  • 1
    Please see How to Answer?
    – mtk
    Commented Mar 1, 2013 at 9:46
  • What's wrong with this answer ?
    – 3bdalla
    Commented Mar 4, 2015 at 11:25

I just tried this and it worked with "no problems". Meaning check if you have selinux enabled and check /var/log/messages for errors related to it. Either disable selinux or configure it properly.

Check if you have firewall up:

systemctl status firewalld


iptables -L

If so, disable (for testing) or configure firewall to permit the vnc connection.

And ensure you are connecting to the correct port of the service.

 cat ~/.vnc/localhost.localdomain\:1.log |grep Listening
 vncext:      Listening for VNC connections on all interface(s), port 5901

Ensure that the log file is the correct one. From the client side don't forget to specify the ip:port ex:

EDIT: adding my config




I use vino instead of tigervnc-server and have no problems to connect to fedora 18 with gnome3. I just installed vino per sudo yum install vino then you have to start the server with /usr/libexec/vino-server & and then you can connect to your machine with any vnc-viewer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .