0

I have two different mounts to share, both on separate disks.

/dev/sdb1 - /mnt/mount1 /dev/sdc1 - /mtn/mount2

However, when I mount them with mount -t nfs server.ip:/mnt/mount2 /mount2 , the show they are sharing the same disk and touching a file from the client populates in both shares:

server.ip:/mnt/mount1               8.0T   93M  7.6T   1% /mount1
server.ip:/mnt/mount2               8.0T   92M  7.6T   1% /mount2

My exportfs looks something like this:

/mnt/mount1       0.0.0.0/0(rw,no_root_squash,insecure,async,no_subtree_check,crossmnt,fsid=0)
/mnt/mount2       0.0.0.0/0(rw,no_root_squash,insecure,async,no_subtree_check,crossmnt,fsid=0)

df -h on the NFS server shows this:

/dev/sdb1                          8.0T   93M  7.6T   1% /mnt/mount1
/dev/sdc1                          2.0T   81M  1.9T   1% /mnt/mount2

How do I separate them as individual drives/mounts? All I did was add a the disk, mklabel/mkpart, mkfs.ext4, mount /dev/sdb1 /mount1, chmod 777, and chown nodoby:

0

1 Answer 1

0

fsid=0 for the mount options in /etc/exports was the same and should be different. This works now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .