1

I don't know why, but I've needed to remap my super key. It got erased somehow.

I logged the keypress as 248 using xev, then used xmodmap -e "keycode 248 = Super_L" just to make sure the right key was mapped, and then I set mod4 using xmodmap -e "add mod4 = Super_L".

That set the left super key as super. But when I tried to press and hold the super key, the system doesn't recognize the hold. Too confirm this, I opened showkey, which confirms that keycode 240 release immediately follows keycode 240 press with no delay.

How do I set the system to recognize a hold of the key, rather than an immediate press-release? I need this functionality in order to use super shortcuts, obviously.

6
  • Does this happen with other keys, that is if you press and hold the space or 'a' key does xev show a release event for the space or 'a'?
    – icarus
    Commented Nov 9, 2020 at 2:59
  • @icarus The release event only occurs when I actually release the other keys.
    – Yehuda
    Commented Nov 9, 2020 at 3:41
  • does it persist after system restart? what is the output of the xmodmap command?
    – Andra
    Commented Nov 9, 2020 at 15:42
  • In particular if you unplug the keyboard and plug it back in does it help?
    – icarus
    Commented Nov 11, 2020 at 7:49
  • @Andra It happens arbitrarily. Last night my machine was working fine. Today the issue has cropped back up. There's no rhyme or reason.
    – Yehuda
    Commented Nov 22, 2020 at 16:40

1 Answer 1

2

It seems that you answered your own question here: Key functionality is disappearing

The solution is to press Fn+Super_L.

It seems that pressing Fn+Super_L toggles the mode of this key between "holding enabled" and "immediate release". At least on this range of laptops. Notice there might be a small lock icon on the key.

It's probable that Fn+Super_L was pressed by mistake.

Also, note that xmodmap -pm -pke | grep Super_L displays (among other lines):
keycode 133 = Super_L (...), so there is already a key mapped to Super_L. The keycode 248 is something else, initially mapped to nothing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .