0

Thanks in advance for the help.

I have a Dell Precision 7540 that has Ubuntu 20.10 installed (previously 20.04). It is a pretty normal installation with a single physical nvme disk, with separate partition for boot and LUKS on the main partition. I can no longer boot past the Grub boot screen. The options I have to select from are:

Ubuntu with Linux 5.8.0-26-generic

Ubuntu with Linux 5.8.0-26-generic (recovery mode)

Both of these options have the same behavior. After 10-15 seconds, it brings me to a (initramfs) prompt. Typing exit gives the following:

Gave up waiting for root file system device. Common problems:
 - Boot args (cat /proc/cmdline)
  - Check rootdelay= (did the system wait long enough?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/mapper/vgubuntu-root does not exist. Dropping to a shell!

Things I have tried: I have tried booting from a Live USB, and I can successfully mount the LUKS partition. I have installed and run boot-repair from the live USB, and after the repair, it gave me a pastebin link, below, but still will not boot:

http://pastebin.ubuntu.com/p/HxXj4qfrqS/

I have also chrooting into my installation and running update-grub, grub-install, and update-initramfs, but none of these have changed anything.

Let me know if there is any other information that would help to diagnose this.

UPDATE: I have gotten it to boot, but only after unlocking the LUKS partition from initramfs. By doing the following command:

cryptsetup luksOpen /dev/nvme0n1p3 nvme0n1p3_crypt and entering the password, then: exit It will boot. How can I make it prompt me for this instead of timing out and dropping me to initramfs?

6
  • You have to decrypt your install for Boot-Repair to work. And you boot to boot live installer and add Boot-Repair in the same mode as you installed. Without LVM being decrypted, we cannot tell, but you have UEFI boot entry and error on grub in gpt's protective MBR. So it looks like original install is UEFI, but you tried to re-install grub in BIOS mode to gpt drive, which will not work without bios_grub partition. But you have UEFI and should not be using BIOS mode. – oldfred Nov 8 '20 at 3:59
  • I did decrypt my install. I used cryptsetup to unlock it. What do you mean by add Boot-Repair in the same mode? Also, I used grub-install. Not sure how to tell it UEFI instead of BIOS. – drearyworlds Nov 8 '20 at 7:00
  • UEFI or BIOS boot mode. If install is UEFI, always boot in UEFI mode as both installing & repairs will then be in UEFI mode. You at some point repaired in BIOS mode as you installed grub to MBR. – oldfred Nov 8 '20 at 13:40
  • I got it to boot finally. Do you know what needs to be done to be able to have it prompt me for the decryption on bootup instead of having to manually unlock it every time in the initramfs prompt? – drearyworlds Nov 8 '20 at 16:33
  • Do not know encryption, but thought grub auto added support. After booting have you run sudo update-grub ? See example /etc/default/grub, but not sure if only place. May need adding modules in grub like insmod lvm or insmod luks orinsmod cryptodisk in grub. superuser.com/questions/1536669/… – oldfred Nov 8 '20 at 16:45
0

You can use a CD or USB stick with Ubuntu Live, download Boot Repair and repair the grub this way.

1
  • I did that. Boot Repair didn't work. The pastebin link shows what it did. – drearyworlds Nov 8 '20 at 15:11
0

Fixed it.

I needed to remove the key file from the line in etc/crypttab (third field) and replace it with none.

It nos looks like this:

nvme0n1p3_crypt UUID=ecb87885-85fa-426d-9242-8b14d23f48c4 none luks,discard

Now it prompts me at startup for the key. I guess the key file it was pointing to was inaccessible or incorrect.

3
  • Since the regular root filesystem is not mounted yet at that point, the key file would have to be included in initramfs. You would have to have something in e.g. /etc/initramfs-tools/hooks that will ensure the key file is added to initramfs whenever it is regenerated (including every time an updated kernel is installed). – telcoM Nov 9 '20 at 7:28
  • It did install a new kernel when I updated to 20.10, so maybe that was it. – drearyworlds Nov 9 '20 at 16:07
  • @telcoM did the /etc/crypttab is automatically populated? – Adi Prasetyo May 10 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.