0

I'm using the Dvorak keyboard layout and KDE Plasma desktop on X11.

Some applications are designed around the Qwerty layout. For example many games use ASDW for the movements.

If I switch to the US Qwerty layout, using the KDE settings, some games keep seeing the Dvorak layout so I cannot move around easily.

  • What's happening?
  • How can I use the Qwerty layouts with those games?

I noticed similar behaviors on other systems too. My friend uses Qwerty on Gnome3 on Wayland. If I switch to the Dvorak layout, I can write in Dvorak, but his browser's control keys still expect Qwerty: I need to press ctrl+qwertyT instead of ctrl+dvorakT to open a new tab.

What's happening there?

0

I have not seen this problem, but I don't play many games.

Some things to check

Check the setting for whether the keyboard layout if per window, per application, per desktop, or global. I have mine set to global, as it is less confusing, as I only switch to querty, if I have someone type for me (pair programming, etc). Per window or per application may make sense for your scenario. However I would try to get it to work with global first.

Add the keyboard layout indicator in the tray, so that you can see what layout is active.

2
  • The Switching Policy is global. And I am using the Keyboard Indicator in the System Tray to switch keyboard. Switching keyboard works in normal applications, but not in all of them, for examples some games. – dvorky Nov 9 '20 at 16:50
  • Does it make a difference what layout is active when the game starts? – ctrl-alt-delor Nov 9 '20 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.