0

I set up my NFS server without doing any bigger changes in configuration files. After that I added these entries to /etc/exports(both paths are valid) on server(192.168.1.11):

/export         192.168.1.0/192.168.255.255(rw,fsid=0,insecure,no_subtree_check,async)
/export/users   192.168.1.0/192.168.255.255(rw,nohide,insecure,no_subtree_check,async)

Then I restarted the computer and I tried to get exports list:

$ showmount -e 192.168.1.11
/export        192.168.1.0/192.168.255.255
/export/users  192.168.1.0/192.168.255.255

According to this output there's not problem with connection. Now I want to mount /export to client filesystem(192.168.1.12):

sudo mount -t nfs4 192.168.1.11:/export /mnt

After typing this there's no output and I can't do anything. Another terminal line start is not being displayed. Command is stuck.

Does anybody know am I doing wrong? Please help me.

  • What OS are server and client running? – tink Jan 19 '13 at 19:16
  • Both are Linux Mint – user35443 Jan 20 '13 at 7:26
1

Looks like you have a firewall active on your client that blocks NFS-traffic.

Configure NFS on the server so that all relevant ports are being bound (for NFSv3), then open the relevant ports on the client (tcp and udp).

For NFSv4 (I did not use it up until now) there is imho just a tcp-port you have to open on the client.

  • How can I open it please? – user35443 Jan 20 '13 at 7:58
  • @user35443 This depends a little bit on your distribution - which is it? Please update your question with the output of iptables-save. – Nils Jan 27 '13 at 20:17
  • by the time I've solved my problem, it was some mess with nfs and nfs4 mounting specifications. But let's tell that you were right ;) – user35443 Jan 28 '13 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.