5

So I have trouble setting the default browser for opening links in zathura. I would like to use chrome however Palemoon is always used instead.

I am on Manjaro with i3.

First of all xdg-open "https://www.google.com" uses chrome properly. When I open any link in zahura following errors are thrown in the terminal:

[1:1:1106/105839.089082:ERROR:nacl_fork_delegate_linux.cc(329)] Bad NaCl helper startup ack (0 bytes)
/usr/bin/xdg-open: line 756: 26008 Trace/breakpoint trap   (core dumped) "$command_exec" "$@"

And Palemoon opens the link. Is it because it was set as default browser in .profile?

Any suggestions?

1
  • It looks like Zathura run xdg-open which starts Chrome but it crashes. Commented Nov 6, 2020 at 11:44

2 Answers 2

8

In your ~/.config/zathura/zathurarc, add a the line

set sandbox none

Follow the issue here.

1
  • 1
    Thanks, worked for me. Commented Mar 4, 2021 at 20:04
0

tl;dr

For me, having xdg-open some-url open a broweser is not enough for zathrura to follow the links. I also had to xdg-settings set default-web-browser my-browser.desktop.


I normally use qutebrowser instead of Chrome, and I had never cared about what xdg-open some-url does, until I bumped into this question because of zathura not opening the URLs.

So I tried what xdg-open "https://www.google.com" did, and it was indeed opening a browser (despite the wrong one, Chrome), but zathura wouldn't follow the links anyway.

Therefore I tried setting the correct browser first:

xdg-settings set default-web-browser org.qutebrowser.qutebrowser.desktop

and then zathura behaved correctly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .